Sansa fuze+ does not work right out of the box

My fiance just purchased a sansa fuze from best buy, brought it home and asked if I could set it up for her. Fine. I took the thing out of the package, and tried to turn it on, nothing happened. Connected it to the laptop, and tried to download the firmware per the instructions. Guess what, the firmware wouldn’t load up. So I check all of the message forums here and am told to do a reset, which doesn’t seem to work either, and to then power up normally. Since apparently the normal power function for this MP3 player is to not work… it’s doing what it was designed to do?


Did you allow it to charge?  If so, the unit must be defective.  Return it.

On the day I purchased two of the six I have purchased since Christmas I encounter two that were bad.  They were both 8GB Fuse+ units.  The first  had a stuck power button. The next was good.  The third  would not play even when connected to power. It had a large battery symbol.  The forth was fine.

When you get a good unit you should be able to play the sample music while in the Best Buy parking lot.

Good luck. 

i had the same issue when i firmst got my fuze+ sandisk support advised me that it was a “low battery state” basically i was instructed to perform a reset (holding the power button for about 20 to 30 sec) then connect it to the computer. it did not turn on at this point and I was told to leave it connected to the computer for an hour and they would call me back. after about 20 mins the fuze turned on and showed a large empty battery which was red. after about 10 more mins it showed connected. when their support called me back an hour later the fuze was connected and charging. They told me that the fuze+ was in an extremely low battery state and to continue charging it for about 3 hours for a full charge. after that i have had no issues with it. 

Strange, it seems to me that Sandisk “precharges” there mp3 players, so how all this is happening is beyond me. I’m pretty sure that mine came precharged, although I had it connected to the computer a while (loading music, updating firmware, ect), so I could be wrong.

I’ve had this happen when I carry the Fuze+ in my cycling bag.  The power button must, on occasion, trigger the little guy “on”.  I have a sensitive power button, I would guess.

The same solution has worked for mine, a soft reset, followed by an hour or so plugged in to the USB port did the trick.  The Fuze+ eventually powers up and resumes charging normally.

Bob  :wink:

I had the same problem. Bought a white 8Gb Fuze+ at Best Buy. It wouldn’t turn on after being plugged in to my PC for 4 hours. I returned it. The second one is exactly the same. I was on the phone with a customer support person who had me do everything she could think of, then conferred with someone else, although she didn’t come back with any more tricks. I have tried it on 3 different PC’s, 2 running Windows 7 and the other on XP. They are all running Windows Media Player 12. I can load songs on the player, and use it as a storage device to play them through the PC, but cannot get it to take a charge.  I’ve tried downloading and updating the firmware, but the installation fails. I just get a message to try again later, and “Thank you for using Sansa Updater”. (!!!) I’ll call their customer support one more time and see if they can help. If not, I’ll return it and get another brand. 

I had the same issue and to my surprise 2 out of the 3 usb connections on my laptop wouldn’t charge the sanza. As you can guess the 3rd one worked a treat.

It’s worth trying all your usb ports.

I beleive that its a factory defect.If you can return it then go.

just went through this problem myself…

i was out at a store when it randomly shut off while playing an mp3.

it was half battery power roughly when i left the house and i was doing nothing with it

when it powered off on its own… sitting in my pocket for an hour or so playing fine.

at that point hitting the power button r holding it made no difference.

at home same thing after plugging it in to my PC a few times it still did nothing

BUT after leaving it plugged in 5 minutes and pulling it out i held the power button for 30 seconds exactly

and while holding the button down still I lugged in the device to the usb port and bingo it powered on !

(Showing me the Rockbox bootloader)

It must have died because of a lack of battery power…

And I have already stated many times that there is something weird with the player i received.

After 1 month of using it before and after work for an hour 5 days a week my battery life was abnormaly bad

and compared to my previous Creative ZEN that took about 6/8 months for the lithium ion battery to decay/age.

Don’t know why but the battery power is an issue on these …at least for me anyways

and i have had lots of mp3 players and know what to expect with charging life and soemthing ain’t right here !

Anyway i wanted bump this and add my 2 cents and confirm this method wrked for me…

just don’t give up too quickly lol