Sansa Express doesn't work


A few days ago i tried to open my Sansa Express, i pressed the power button and as always the sandisk logo appeared. And that’s it.

after a few seconds the logo disappeared and nothing happened, the device didn’t turn on.

Also when i connect it my computer nothing happens, the computer doesn’t recognize it.

Please help, i can’t go anywhere without my music:<


Have you talked to tech support? Also try a soft reset.

Funny that.  I have exactly the same issue.  Did you ever get a response?

how do you soft reset?

hello man just buy a sansa microsd card and insert it into ur sansa express just click on ur boots up from the card then go to settings and format internal memmory.once again telling internal memmorey coz external memmory have ur card datas.then remove the card and switch on your device

Hello there. Same thing happened to me, anyone tried the micro SD solution? did it work? Ill try to get one anyway.

and quoting other member:

First, try a soft reset. Press the volume up (+) button and the center “Select” button at the same time.

Message Edited by smsantos31 on 06-26-2008 10:26 PM

I am facing same problem. Few days before when I turned on Sansa Express MP3 player, startup logo appeared and then nothing happened. It was off. I tried hard reset as per User Guide but no luck.

Now, I tried Firmware update as well but the device itself is not detected.

what to do? Any suggestions?


i solved my problem a long time ago. I just got an email now and i saw u guys still posted here so…

If u have the same problem, look for toturials in this forum, write “Sansa express doesnt work” or something like that, u’ll find planty of threads explaining how to fix the device.

I dont really remember how i fixed mine, u need to put it in the usb while pressing the volume down button for like 10 seconds, untill the computer recognizes the device, then download a driver or something like that…

Look in the forum, it’s all there.

Good Luck.

Try this

I tried every conceivable fix. Those on this site and many others. I buggered around for just about two days. Then I read a tip on some website - can’t remember where. It said I must insert a MicroSD card in the external memory card slot and switch on the Sansa. I have the 1 gig model.

I used my Nokia mobile phone memory card which had other stuff on. It worked first time !!! Sansa back from death and still working without any problems. Even after I removed the card. Unbelievable but true !!!

So simple, when you think about all the high tech solutions that everyboby suggests. I also did the latest firmware update without problems after the card trick.

I use the Sansa on my home theatre for music playback, still the greatest MP3 for that for me

Sandisk, where are you in all of this ??? Surely you should read all these posts and come up with advice ???