My sansa express won't start

hi i got my sansa about half a year ago, and it worked fine until this Monday. I tried to turn my sana expree just like usual days but it wont start up.
u know how it shows ‘Sandisk’ when it starts up? it will not do anything after that. it just turns off.
im not turning it off… (im not that stupid) and i have no idea what is wrong with this. i mean… it worked fine…
if anyone can help that would be great.
thank you

I have had mine about 1 month.

Yesterday, I had a similar problem - I tried to turn it on [at work] and it would show the sandisk name and nothing else, It would not turn on or off and none of the buttons would do anything. when I got home I pluged it into my computer, it recharged the battery and now works with no problems.

I would try and plug it into a powered USB port on the computer and see if it will charge up the battery.

I 'am keeping an eye on the power bar and I try to keep it fully charged.

Hopefully, that will solve the problem [Yours and Mine].

I have an identical problem, although i had this device for only 2 months.
Very disappointing.

It will only show the Sandisk logo after startup for three seconds and then blacks out.
It will show the lock symbol for 5-6 seconds if you are quick enough to enable the lock before it blacks out.

Stone dead.
Hard reset (vol + and center key for 30 seconds) wont do.

No longer detected when connected.
Did not charge despite having it connected overnight.

Any ideas?

hi all,
I face the same problem, it is really disappointing. Please let me know if there is something I can do.


i had the same problem. plug in any blank, formatted, microsd card and it should boot up. then format internal memory. thats it.

Hey guys i posted this thing couple days ago, maybe a week, and i’ve found a solution.

Im not sure if this will work for you guys too or not, but it worked for me.

I just upgraded my firmware.

How u do this is go to

and click on “download Sansa firmware updater”

and when u’re done downloading it, just luanch that program.

U dont plug ur sansa first, it will tell u when.

I hope this works for you guys too, cuz i was really happy when i fixed mine.

good luck guys!

My express had the same problem only logo would show up then turn off, nothing worked. I put in a memory card into the slot then it automatically started up saying “building database” over and over until I pressed the Power button and it then turned ON fine and has been working perfect since, no need to reformat internal memory or reload music.

I’ve just encountered this problem.

I plugged the SE into my computer and transferred some songs. At the end of the process my computer told me that if I was doing something data might be lost because of a fatal exception[feh, windows, go figure] but now, my computer won’t even recognize the Sansa Express! I wouldn’t have a problem with this, my computer has stopped recognizing it before, I just run the battery down and plug it in again, all is right in the world.

But this time, my Sansa Express stopped working all together. When I unplugged it from the computer, the ‘SanDisk’ startup logo appears, but then it leaves and nothing replaces it. Music doesn’t play, and I can’t bring any menus up. I tried the hard reset but when I power it back up, it just does the same thing. SanDisk, and then nothing.

It doesn’t start charging when I plug it into the computer, or at least the OLED doesn’t tell me it is. The computer doesn’t recognize it at ALL and I’m starting to get a bit miffed that I think my Express is broken somehow.

The updater didn’t work for me. It seems that it also encounters a fatal error. and then it asks me to send an error report.

Our Sansa Express has same problem.

Push power button and all we get is Sandisk Logo for few seconds.  Then goes off.

Charging hasn’t helped.

Hard reset (vol + and center key for 30 seconds) doesn’t work for us either.

A few weeks ago the unit came up in Japanese.

Wife was able to correct this though.

Firmware updater isn’t an option.  We have WinXP but I don’t allow  that O.S. to access Internet.  Win2000 doesn’t seem to be supported.

Plain foolishness on Sandisk’s part to require this automatic update procedure via WinXP.

Am I happy?  not the slightest.  If not for my wife liking these MP3’s I’d toss in trash and never buy another.

So, any more ideas?"


Message Edited by ptkaneman on 09-27-2007 05:15 AM

I followed the advice from another post in this thread.
The MicroSD method works well.

I bought a MicroSD, plugged it in and the player started to work right away.


To fix the problem with it not coming on here is what I did:

1.  Installed a external memory chip.  Lucky I had one around

2.  Updated the Firmware.

Now I cannot copy anything to the chip or internal memory directly or through Windows Media Player.


Here is my Fix

  1. SE would not power on just flashed on the screen

  2. Inserted a SD chip - Started working

  3. Flashed the firmware.  Arrgghhh!

  4. Could not add media to SE

  5. Deleted driver from WinXP

  6. Reattached SE and updated the driver

  7. Works!

I hope this helps other folks with the issue.

Hasn’t anyone figured out a way to do this without me having to waste more money buying an SD card to fix SansDisk’s failure?

Message Edited by Lyrelia on 11-11-2007 06:56 AM

This issue has happened to me twice. Both times it seems, were caused by a depleted battery. I’m running WinXP 2003 Media Center Edition. The first time I was able to plug it into another machine running Win2K. It was identified and began chargining right away. The next time, a small unidentifiable symbol appeared on the screen and I couldn’t get it to be identified on 3 diffeent computers. Eventually the symbol went away and I was able to recharge on a Win2K computer.

I think the battery had to reach a low point before this could occur. Just guessing.

I have almost the same problem I can’t even get mine to turn on. What should I do?

I have the same problem!! same thing with the lock postion… I’m running Windows XP, sp2 and everytime i plug it in the USB port, it says MTP device found, but when you look at the sandisk web-site, it says you have to be in a MSC mode.

This mp3 player maybe trash soon!!    Please help???

I had same problem yesterday. Just connect it to some linux machine. It will connect as normal USB drive. Open it and delete everything. If you want to keep music, don’t delete folder Music. That is all. I had same problem several times and this has always worked. :wink:

Message Edited by mandrake on 02-19-2008 12:29 PM

I had the same problem but I cannot put it in MSC mode, obviously the bloody thing wont start, so I don’t know how they want me to be able to change a setting…I tried downloading the firmware but it mentions it should automatically starts an update or such, but after i plug in the player after downloading the firmware, does nothing. The pc doesn’t even detect the player…

My Sansa Express too has the same problem now.

I just plugged it in for charging when i was working in linux. Then i switched off the PC, the Sansa express got stuck in the Connected Display. I couldnt switch off the Device. Gradually the battery drained out. Now it is not recognised both in WinXP and Linux. The Firmware Update didn’t help. Please suggest me some way out.

Message Edited by senfunn on 03-01-2008 10:13 AM

This can happen if media player (Amarok or Rythmbox) is configured to recognise Sansa Express as MTP device. Unplug Sansa Express, configure media player to see Sansa Express as disk drive or generic audio player. Plug in and player will begin to charge and you will be able to delete files. Main problem is if you unplug Sansa Express without “Safely remove” some of the root (system) files that contain informations about music on the player, can become corupt and player can not read them and will freeze. Just clearing all files will force player to generate them again (some minor settings will be lost).

Been there, done that  :wink: