Sansa Express will not turn on

The Sansa Express 2.0GB  worked fine for two weeks.  Now, it will not turn on and will not appear on my computer.  If I press “ON” button, it says scandisk and shuts off.  Does nothing when I plugg it in computer. I tried a hard reset.  Any suggestions?

exactly the same here!!!
There is no reset of the Sansa Express possible because you can’t turn it on.
If you plug it on an USB-device you cant see the stick in your explorer.

You know what? I’ve been having the same problem. I think most near everyone has been having the same problem. Resetting doesn’t work, the hold switch isn’t in the ‘on’ position, leaving it in the usb port overnight does no good. I’m just about ready to return the damned thing since nobody from the copmpany seems to care about getting their product fixed. I’ve searched the internet far and wide for any viable solution, and there’s nothing being made avilable by SanDisk. Frankly, I’m too frustrated to deal anymore. If it -is- a firmware problem, how am I supposed to fix it without being able to connect it to my usb port or turn it on? Seems a little ridiculous to me. /rant  I’ll let you know if I can find any solution. Nothing seems to really be consistent with the failure. It just stopped turning on for me one day after it had been working fine for months.

Message Edited by Lyrelia on 11-11-2007 06:56 AM

Yes same here. I had it over night on the usb-port and now it doesn’t start anymore. Maybe this damaged something, but there is no reaction from SanDisk.

Yes I am also having the same problem .When I am switching on the power button only the sansa disk display is coming for few moment and then the display is disappearing. My computer is also unable to detect the device…Resetting doesn’t work, the hold switch isn’t in the ‘on’ position, leaving it in the usb port overnight does no good. Nobody from the copmpany seems to care about getting their product fixed. please help me if you have any suggestion to fix this problem…

I am echoing the previous posts. My Express will turn on and run IF it’s not plugged into the computer. I have a MicroSD 2gb chip that I had to use with an external MobileMate SD to sync w/ WMP 10; the Express recognizes the chip and contents, but I cannot get the Express to turn on while attached to my notebook.

As with the others, I would appreciate a “fix” if someone knows of it. It will only charge while connected but not turn on.

Hey, what thee heck.  Mine just did the same thing, it’s kind of hot to the touch too…I did a google…this site came up.  Now what?

Press and hold the square button, while holding the volume up + button.  It resets, it should be able to be charged and detected after doing that I guess.  Worked for me.

Thanks for the reply. I did the soft reset as you described, and it worked the first time. Then, it reverted to not turning on but just charging when connected. I’m still working at looking for other “fixes” based on other forums. If I locate anything, I’ll attempt to post it.

Try the micro SD trick if you dare.  I bought a 2g sandisk uSD card and when the player does this, plug in the card and power up again.  It might need to be a Sandisk card.  Funny, huh?

There seems to be lots of posts on the forum on this issue.  But no answer to the problem. Every descripion seems to be the same. Does anyone know why Customer Service and Tech Support are not responding to my e-mails about this.  Has anyone recieved an answer from SanDisk.  Thanks.

I also have the same problem as everyone else on this page. Does anyone know how to fix it yet?

I did have that problem and found it worked fine when connected directly to a USB 2 port on my computer. Once I replaced my USB hub with a hub that was definitely a USB 2 hub it worked the way it was supposed to. Now if someone can help me get it to work with Rhapsody (I posted the question) I will be happy. Works fine with MP3’s that I don’t have to buy.

my express shutoff during playback of an mp3 tune.  it was fully charged.  after each hard reset, i was able to get the logo to appear when i tried to power it up, but it shutdown after 2 seconds (just an approximation) of displaying the logo.  until the next hardreset, it was totally dark and silent.

when i attempted to plug it into my computer (several towers, laptops, and hubs actually) the display flickered a small area in the center but i never recognized an icon; it flashes and disappears immediately.

after reading this thread (and others) i bought a SanDisk 1GB microsd from radio shack and plugged it in.  the player now works.

i haven’t tried to use the sd memory yet.

i’m happy that the player seems to be back and happy, but a little resentful that i never got any response out of sandisk, and that my solution (perhaps not the sandisk recommended solution) included plopping 20$ down for a uSD to “fix” the express.

-jfg

My express will not turn on (I just get the SanDisk display then it shuts off), so I downloaded and ran the firmware updater.  It DIDN’T WORK.  I got an error message saying “Your device is in MTP mode.  It can only be updated in MSC mode.  Please unplug and switch to MCS mode.”

So how can I switch to MCS mode if I CAN’T TURN IT ON???

It does seem sort of coincidental that it takes a Sandisk branded usd card to “fix” the Express.  There are countless threads about how the fw update broke other branded usd cards.

I have sent email to SanDisk support.
I bought SanDisk brand because they have a good rep. but…

SanDisk needs to disassociate itself from this player.
I am trying to return. Unit lasted only 3 weeks and now behaves like everyone is posting.
I read good reviews about this player, and later found this forum after buying one and having problems.

I am very disappointed by SanDisk.
I am not prepared to go out and buy a MicroSD chip to fix this issue.

Hey I my Sansa Express is doing the same thing has anyone found any answers yet?   This sucks!!  Thanks for any help :slight_smile:

I have had the exact same problem.  I returned it and was sent a new one that behaved the same way.  There is obviously a problem with the design of this device.  I wish Sandisk could come up with a fix but customer support seems clueless.  They just read from a script that doesn’t help with the problem.

    Add me to the list… Yesterday, I tried to change to another song, but it wouldn’t do that. After several attempts, it just went black. I was sure that the battery was charged, but I put it on the charger anyway. Several hours later I attempted to turn it on, but nothing happened. I checked to see if it was still under warranty, and it was. I decided to check the forum just in case, and found I had lots of company. One person mentioned resetting it, and I had done that once before for a different problem. I gave it a try, and held the buttons down for at least 30 seconds. Nothing.  Again. Nothing. Again. Nothing. Put it back on the charger, and went to get some ice cream. Returned to my computer, and guess what…it was alive! It was on a radio station, but I wanted some music, so I tried to get it to play a cut. It wouldn’t at first, but after several attempts, it started playing.
    I have a feeling that it will quit again, so I may be back. Good luck.