Something is wrong with my Sansa Express

I bought a Sansa Express from Best Buy a couple of weeks ago. It is brand new, just got it out of the box, and all I’ve done to it was listen to music. When the device died, I attempted to charge it to a PC. After a few hours, the device was hot, so I umplugged it. When I tried turning it on, the SanDisk logo appeared, and that was it. I could not listen to my radio, and I never had a chance to put any music on it.

I tired soft-resetting, did not work. I can’t update the firmware because even though the PC recognizes that the device has been hooked up, it does not appear in Windows Explorer or Windows Media Player.

I can’t find the receipt to return the product, and to be honest, I don’t want to return it! I like the little thing, and I would do anything to repair it. Please help!

Try this

I tried every conceivable fix. Those on this site and many others. I buggered around for just about two days. Then I read a tip on some website - can’t remember where. It said I must insert a MicroSD card in the external memory card slot and switch on the Sansa. I have the 1 gig model. I used my Nokia mobile phone memory card which had other stuff on. It worked first time !!! Sansa back from death and still working without any problems. Even after I removed the card. Unbelievable but true !!! So simple, when you think about all the high tech solutions that everyboby suggests. I also did the latest firmware update without problems after the card trick. I use the Sansa on my home theatre for music playback, still the greatest MP3 for that for me Sandisk, where are you in all of this ??? Surely you should read all these posts and come up with advice ???