Sansa Express 1g died

  I have had my express for over a year now with no major problems.  Tried to listen to it today and all it does is show sandisk on the screen for 5 sec then shuts back off.  I have tried everything and can not get it to work so wondering if anyone else has any ideas.  When I try to download the update off sandisk website it comes up with error #1003.  Thanks for any help as I like my express alot and do not want to replace it right now.

I have exactly the same problem, except that I’ve only had the Sansa Express for less than 2 weeks! And it was working fine - till yesterday- then today I opened it to find it only shows the Sandisk logo on the screen for a few seconds, then screen goes black again; it’s bricked! and for absolutely no understandable reason, I did nothing to it! I was wondering, have you found a solution to fix yours? I tried following the instructions here on the forum: of people who had the same problem, but still nothing happened. They said to install a new driver on it, then update the firmware, but the firmware updater doesn’t detect its presence. When it’s plugged in the computer, the computer detects it but doesn’t show its contents or open it or play it. It just shows a weird chinese-like character on its screen when it’s plugged in, or it shows that its charging from the computer but when I unplug it it still doesn’t work.

I don’t know what could have caused it to suddenly stop working like this. I emailed their tech support ( just now, and am waiting, if there will be any result.

Have you or has anyone found any solution to this problem? It seems many other people are experiencing this ‘bricking’ of their Sansa Express??? Thanks.

If you have an expansion card use that. Mine was bricked also. It would only stay on long enough for the startup screen to run, then shut off too. So I put in the card and it starts up fine. I have updated to latest firmware and have had no problems . I read about the card trick on this forum, and also got the update here as well. Did a manual install on update as I am useing a win98se computer.