2GB Sansa Express not working!!! tried everything

Hi ive been trying to get my sansa express to work but its just not happening. Ive tried hard resetting, installing and uninstalling, for some reason it wont let me format the drive when its hooked up. It recognises it but doesnt alocate a drive to it nor does it show up as sansa express. I press the on button all it says is sandisk and then nothing. When i go to safely remove hardware it shows up twice as in F: and E: all the time but i cant get in those drives or anything.

Also, when i go to the Sansa Updater it says no updatable sansa product has been recognised. In device manager it shows up as either sansa express twice or player recovery thing (forget what it says) only once under portable devices.

Ive followed instructions to reset it without the SD Card as im not able to get one at the moment but to no avail. Please can someone help, i hope its not dead and needs to be thrown out. Please help.

Thankyou

Message Edited by starr5050 on 10-24-2008 07:33 AM

I had the problem with my 1 GB Express that when I turned it on, all it would say is Sandisk and then go black and nothing would happen. My computer wouldn’t even recognize it though. I called the tech center/service support number, and they were very helpful.  They had my try a hard reset and a few other things, none of which worked.  So they emailed me a pre-paid UPS label, told me to mail it in, and they mailed me a totally new and free one! It was in the original package and everything. It was totally free to me, the only bummer was waiting a few weeks to get the replacement mailed back to me. This has happened twice, so I am on my third brand new Sansa right now!

Hope that helps…

Martha