Sansa express quit working (seems to be a new problem)

Got a new 2 GB sansa express a few weeks ago. Worked fine up until last night. I was adding some music to it. After it was done, when I try to turn it on, it says “Reading database”, the status bar flashes along as if it is doing something, and then it powers off. I’ve tried doing the hard-reset. It has no effect on this (I have had problems where it freezes and needs a hard reset though). And now… when I plug it into my computer, the computer doesn’t recognize that it is plugged in anymore, so I can’t format it. It does, however, have the little dog on the screen when it is plugged in and says “connected”. It effectively seems “dead”. I don’t know what I can do to fix it if I can’t format it and it won’t get past “reading database” when I turn it on. Any ideas? I have no idea what firmware it is since I can’t check it, but it was whatever it had when I got it a few weeks ago.

Try to do the vol + and gray square trick to turn off.

once its off, connect to pc, and see how it shows in device mgr

Buggy SE isn’t it?

Try the MSD trick. (Push it in and take it out blah blah).

I got the SansaExpress 1GB as a prize for completing a project last Thursday.  I’ve been using it (and charging it) all weekend.  Today, I tried to add some more songs, and now it’s doing the same thing as the original poster mentioned.  Not even four days.  I liked it so much that, on Friday, I ordered an expansion card for it.  Doggone it.

This has happenned to me twice. Once before and actually today as well.

Both times the preceding event took place to cause the malfunction, if you want to call it that.

The event was the PC rebooting. Once that happens and if the Sansa stick is in the USB slot, the stick fails to operate normaly, in that it does not respond at all.

The first time I just let it lay around a few days and it actually seemed to work when I plugged it back into the PC. The differance is that it seemed to need total recharging. In fact I know that it was almost charged when it failed to work prior to the first event happening.

The second time,[after the reboot] the Stick failed to operate again. This time a checked the “net” and found out that if you press the Grey square on the sansa stick and hold the + volume it reboots the Sansa, however that did not work, instead I held the square box and the power [side] button. That seemd to reboot the Sansa stick. I then plugged it into the usb slot and presto it is now charging.

This is a great little machine, I love using it.

Hope this helps.