New Sansa Express 1gb completely bricked

Hello folks,

I’ve purchased a sansa express 1gb and got it today. When I just got it it had a display but I didn’t test it for music.

Trying to update the firmware (with the nice GUI tool) failed, so I tried the manual update, which completely bricked it.

Current state of the device:

  • No display at all

  • Hard reset does not work at all

  • If recognized by Windows (7), it’s a simple mass storage device.

  • Unknown whether it charges when connected to my computer. Device has no display. 

The things I’ve tried:

  • Holding (-) while plugging it and using the manual firmware updater either 1.01.12a or the 05 one. Result: Update process does not progress at all after telling me I need to format the disk.

  • Stuffing a MicroSD card in the device and turning it on, plugging it in with (-) held, etc. Result: Nothing.

 I’ll stress that I’ve went through the “how I unbricked my …” thread with zero success. This device refuses to be recognized as anything other than a mass storage device.

Any help?



A few more data points in case it will help:

I tried using the Sigmatel firmware downloader, but it forever seems to be “initializing” once the device is recognized.

The Sansa Updater, when trying to update the firmware, always causes Windows to pop up a window saying the device needs to be formatted. Whether I say yes/no to that doesn’t change anything in the end result as it still hangs.

Any ideas on what I can try? I mean, the device is obviously responsive and something just needs to “raw write” the firmware to it. Maybe if someone can post the partition table of the device and the layout for the firmware partition (if it appears…) I could use standard tools to recreate whatever’s been lost by a format?

Just random thoughts… Thanks for any help! :slight_smile:

Had the exact same problem!

I’ve tried everything including this: (take the American, the European have no FM


didn’t work in win 7, even in compatibility mode.

After few days i tried it on real XP computer, worked out fine! after 5 minutes my Sansa Express was like new one!

“would not happend in Linux…” :wink:


Have the same problem. It’s dead.

The link in the previous post won’t work.

Any suggestions,


EVERBODY! I Just found the answer!..It MUST be done on a Windows XP system. Run the updater MANUALLY from the desktop folder. Good luck!..(finding an XP system)