Got some problems.

Hi, I was extremly satisfied with my SanDisk Sansa Express purchase at the beginning. But then i thought about updating the firmware and after waiting one hour of the update i gave up and disconnected my Sansa Express. After that it has never worked again. When trying to start the Sansa Express it shows the SanDisk logo and then turns off, And when i connect it to the computer it says that it’s detected my Sansa but when it asks which software i wanna use to synchronize i use Media Player 10 and it opens WP10 but after a while it says “Didn’t detect any portable device” or something similar.

After that i tried to follow a guide that i read here, That said i would need to put in the Sansa Express while holding (-) volume down button, Which i did and it loaded. But now i’m trying to install the new firmware again and it starts and says “Warning: Do not disconnect your device” but it doesn’t advance anything on the bar below the text and i’ve soon waited for one hour again.

So is there any way to just wipe the whole MP3 Player and just install the firmware successfully?

I’m a Windows XP SP2 User, Have a Sansa Express 1gb memory. with no additional memorycards yet.

Thanks in Advance

At the moment my biggest issue is that my Sansa Express won’t work at all, I start it but it shows the logo and then turns off. I guess this is because i canceled the update of the firmware.

So how am i suppose to get it start at all? When i connect my Sansa Express it says it has found a new device and two disks pop up in “My Computer” (Using MSC Mode) but i can’t open either of them, Says it didn’t found any device. Same as in WMP10.

Anyone knows how i can turn it to default firmware and wipe the whole darn thing without using a computer or how my computer will detect my device properly?

I don’t have any reciepts left from the store so i guess i can’t turn it back there for them to fix it, And i live pretty much across the world from America so i doesn’t look like a good idea to send it to SanDisk for support, As it will be cheaper to buy a new one.

Did you try the manual updater?  It does not use the Sansa Updater across the web, which might be the issue.  Here is the link:

It worked for me where the official one would not.  Hope you get it going. :smiley:

That’s the one i used, Which didn’t work.

What’s the default firmware that the Sansa Express has when purchased? Was thinking i maybe could try updating to the old one.

Give this a try.  I had this firmware when I bought my player and never had any problems with it.  Others have tried this update and it worked for them when 01.01.01a was buggy.

Unfortionatly didn’t work either. I double click the file and the window pops up that shows the updating process and the “Do not disconnect your device”-warning. But the process doesn’t move anywhere, It doesn’t happend anything.

Is there any way to format the device? Because i think that’s the problem right now, Need to format it before i install the new firmware.

But thanks nosync for the other firmware, Will test that one after i’ve figured out how to format it.

I ran into a similar problem, and found help in this thread:

You must hold down the volume minus button while connecting, and keep it held until Windows shows that it has found a new device, STMP3600. You must be connected to the internet, and it will do so. If you have a slow connection this may take a while.

You might try uninstalling the current device, so that it is starting from nothing, though that shouldn’t be essential. The Sansa Updater should work once it has installed the recovery device driver.

The firmware updater will format the device.

An alternative method which works is to put a microSD card in. When that works, you just select format internal memory (or update firmware, which does that as well).

I think we need to compile the recovery methods, especially since they differ depending on OS a little. Lacking a high-speed internet connection makes recovery difficult. There are links to firmware installers that download in full, a help if you have a slow connection.

Message Edited by Inkadinkadoo on 01-13-2008 12:33 PM

Ok, Thanks!

I haven’t tried yet but i will try to ressurect my Sansa Express now!