Sansa Express - AData Micro SDHC 4gb not working - Compatible SDHC/SD Cards?

Bought a Sansa Express… after returning Sansa Clip for the up volume breaking, and the Sansa Fuze because it turned in to a brick after firmware malfunction…


Can not get my Adata SDHC 4GB card to work

Tried to drag and drop, tried WMP Sync,

formatted it in the Express (doesn’t even remove files?)  

formatted it in windows under default fat32  (is there a specific allocation size?)

formatted it in blackberry phone,

tried everything

The express says it refreshes, but doesn’t see any of the songs

  1. does anyone else have this problem with possible solution and if not???

  2. List your make/model/size MicroSD card that you got to work in it, and how…so I can buy it =]

Fixed it…

Format the card using the cmd prompt… format driveletter: /FS:FAT (Believe that is the right command)

then i just dragged and dropped files on…

the mp3 player reads them, and *plugging it up*

hmm, haha, its froze on the sandisk logo…

ok, held down the select button and volume up, turned it on…lets see

 ok i guess it’s working!!

 i’ll keep everyone informed

thank you myself =]

It is my understanding from reading one particular thread from among much more recent posts that the Sansa Express requires San Disk brand micro sd cards and to enable the other brands one must perform the firmware update. I hope this helps.

Not sure i buy the SANSA SD card excuse.   My express has no problems with several 2Gb Class 2 cards, but wil not properly build the internal database using a Kingston 4Gb Class 4 card.   The system recognizes the card but it will not read the files even when I load the exact same songs as on the 2Gb cards.

I have done the updater and still have the same problem.  Something else is going on.

I have gotten a Kingston 4GB Class 4 (SDHC) to work with a 1 Gb Express.

The trick for me appears to be to change the default shut down time from 2 minutes to 5 minutes.  It appears the initial database build needs the extra time to complete.

Then you have to be patient.  Start up takes almost a minute after that.