Sansa Express 01.01.05a firmware released!

Let me start off by saying that majority of people will be able to update his/her firmware through the Sansa Firmware Updater. There is even a how-to video that explains the process. If for any reason the aforementioned steps do not work for you, then please feel free to continue by trying the more “computer savy” steps, described below.


Hello all,

I have received the 01.01.05a firmware for the Sansa Express. I was told this is the latest version thats on the updater. So if you’re having issues using the Sansa Firmware Updater, feel free to use the firmware files and instructions below.


For AMERICAS - You can download the .zip file by clicking on this link. ; *only American version is currently available.

  1. Unzip the files into a folder on your desktop.
  2. You’ll see a file called “StMp3Rec.sys”, move this to “C:\windows\system32\drivers”. If you already have this driver, no need to overwrite the files. You should also see another folder, this is the firmware update folder.

Back up everything that’s on your device. The firmware update may delete your files!
3. Press and hold the (-) volume button while plugging in device to PC. This took me a couple of tries, but eventually it connects with a drive letter instead of the “Sansa Express”.
4. If there’s message asking to install driver, choose “Yes, one time only” and follow the steps to complete driver installation. You should already have the driver as it is included in the zip, but it doesn’t hurt to verify.
5. Now, open up the firmware folder and double click on “SansaExpressUpdater.exe”.
6. A message will appear informing you that updating this firmware will erase everything on your device. 

If you have not backed up your data, then please do so, or you’ll be sorry! Once backed up, proceed with the update process.
7. Once the update is completed, click on “Finish” and wait for 2 seconds before unpluging your Sansa Express from the computer. This ensures it is updated completely.
8. Now, you’ve completed updating your device. 

Enjoy Guys!

Message Edited by MrSmileyFace on 03-11-2008 02:57 PM

I have tried this in windows 2000 service pack 4. Of which when holding down the - button and inserting the express it prompts me to install a device of STMP3600 (which I believe is the sigmatel chip used in the express). I then proceed to find the driver it asks for which seems to be: $winnt$.inf in C:\WINNT\system32 which does not work and says this driver is not correct for this device. When opening up the sansupdater.exe from the folder the program is ran stating “DO NOT REMOVE DEVICE” yet another dialog is presented stating “Error: unable to open bootmanger.sb firmware file.” closing the firmware program and removing the device leaves me with the original firmware. How can I get this firmware working? What are the benefits of this new firmware? Screenshots: http://img172.imageshack.us/img172/9225/locatefilewb2.bmp http://img261.imageshack.us/img261/4775/unabletolocatepd7.bmp http://img515.imageshack.us/img515/2926/bootmanagerct2.bmp"

Hi jake,

I followed your instructions and my Sansa worked.
Thank you very very much for your help…

Regards,
snowsg

Thank you very much.   After reading the forums, it seems many people have had lots of problems with the SE.  Your advise worked perfectly and saved me a lot of headaches. My SE works perfectly again.

I got the "“Error: unable to open bootmanger.sb firmware file.”  as well.   So I went back and extracted the files into a different folder.  I then went to that different folder and made sure that the Sansa updater and the  bootmanger.sb file where both in that folder.   Then I ran the updater.  It went through the process (takes awhile - at least 5 mins for me) but finished successfully.   NOTE:   It does have to totally reformat the player, so expect to have to reload it.   I couldn’t worry about backing it up, because it wasn’t recognized by the computer.

It’s working now.    HOWEVER, this is the second “solution” I have tried to this problem.  Both solutions have been different, but have worked.  The last solution ending up failing about a week ago (lasted at least one month).   I’m hoping for better success this time.

Good luck!

Hi,

I got 2 x 2GB sansa express players (UK) from amazon.co.uk (no radio)

The first one updated with the sansa express updater itself, the second didn’t seem to so I ran this update, and it is now showing as a USA player - firmware 01.01.05a (all working fine)

Imagine my surprise when there’s now an FM radio option on the menu, and IT WORKS!

Not sure if I’ve fluked out here and got one player different to the other !

When registering the second I noticed what I thought was the serial number on the back of the unit was the same so must be some model number, BE0707XDB

Now I’m 99% sure the other one didn’t have radio, I didn’t test this one before updating firmware as reading all the notes here - new firmware solves a lot of problems!

The other is wrapped as a present and will be opened sunday, I’ll confirm the firmware version on it then, the region and also if it has the radio - I’m sure it Didn’t though as that model was twice the cost on amazon.co.uk, these were £25!

Make sure you use a 32 bit PC if you’re going to attempt this. I’ve just had a lot of heartache trying to do it on my 64 bit PC. I thought that I was going to have to try to get SanDisk to replace my beloved express. Otherwise this work this works like a charm. Thanks a lot :smileyvery-happy:

I have a Sansa 2GB and it won’t work. I mean it won’t even turn on! Support has adviced me to several methods and one being to update the firmware. I tried the above but the thing is that I can’t get past the “install driver” stage. Windows Vista can’t find the drivers, even the one included in the .zip file (which I extracted to the adviced folder).

Does someone know what’s wrong? The fact that the player won’t start properly (it only says SANDISK, then it shuts down). Maybe it crashed after being used with both Windows XP and Windows Vista. I got it to work with XP, then 2 weeks later I tried with Vista, but it never worked…

Please help!

Vista tends to be… “special.” I have a number of devices that just won’t do things like firmware updates properly whenever they’re used on Vista - it breaks darn near everything. So… have you tried it on XP instead?

Message Edited by kennyj on 03-27-2008 01:15 PM

First of all thanks jake:)

I just wanted to share my experience of my SE, only had it 2 days,updated and working ok but decided before i got it to do research on this player and have to say it was pretty much 50/50 on good and bad reviews but as it was so cheap i took the plunge.

First of all i tried the firmware updater but as i had already put it into USB mode i couldn’t remember how to get it back to MTP (Media Transfer Protocol) mode so assume thats why i couldn’t get it to work,after uninstalling the updater i decided to do it with the .zip that jake supplied the link to.

This is exactly how i got my SE updated to 01.01.05a firmware:

  1. Put the player in USB mode like so:

(1)  Right-click on My Computer then select Properties.

(2)  In the Hardware tab, click the Device Manager button.

(3)  Find the Sansa Express device.  (It should be in the Portable Devices category)

(4)  Right click on the device then select Update Driver.

(5)  Choose “No…”, “Install from a list…”, and then “Don’t search…”.

(6)  Check the “Show Compatible Hardware” checkbox if it is unchecked.

(7)  Select “USB Mass Storage Device”, click Next, and then click Finish.

Thanks to Thomas for that info on another thread.

  1. Download the .zip for the 01.01.05a firmware

  2. Unzip the files into a folder on your desktop

4.You’ll see a file called “StMp3Rec.sys”, move this to “C:\windows\system32\drivers”. If you already have this driver, no need to overwrite the files. You should also see another folder, this is the firmware update folder.

  1. Found my device drive,mine was H,copied everything from it to another folder to make a backup.

  2. Opened up the firmware folder and double clicked on “SansaExpressUpdater.exe”,a box them appeared with a large yellow warning symbol showing the firmware was being updated.

7.Closed the updater box onced finished.

  1. Unplugged my SE frm the USB port and checked to the firmware version in the settings.

I took the risk of not following jakes instructions by not holding the (-) volume button while plugging in device to PC but didn’t think i had to seeing as i already had a drive letter.

I will also add that i live in the UK and the firmware as i understood it was for the Americas only,this i believe from what i read from other threads turned out to be a good thing, because with my old firmware i didn’t have a radio (even though it was advertied with one) but now with the new firmware i have the radio.

I hope this may help someone else but can only give my experiance how it worked for me with the help of jake and thomas and would also like anyone to comment/critisize if i have made a mistake in my explanation as i know many people have had a very frutrating time with this particular player.

Message Edited by Nitro on 04-06-2008 03:44 PM

Message Edited by Nitro on 04-06-2008 03:46 PM

I signed up just to post this…I was near throwing my sansa away and buying a refurb…

This is the only thing that worked

I was stuck in recovery mode but couldnt do anything…

this is from another site…so ill post the url and paste the info

http://www.anythingbutipod.com/forum/showthread.php?p=241814#post241814

I’ve read up on just about every problems there’s been. From what it looks like, your sansa isn’t accepting the files because you installed the beta firmware, which uses different filenames. A missing version.txt file could possibly be the cause, but I haven’t experimented with that enough yet to know. Try the following:
Go into recovery mode: Turn on hold, begin holding record while turning your player on, and release REC when it says “Welcome to Recovery Mode”. At this point, grab the file’s you’ll need:
Based on your problem, you’ll probably need all four files to fully clean your sansa:
The bootloader, the firmware, version.txt, and sansa.fmt.

Grab the version.txt file advcomp2019 posted on the first page, and save it on to the 16MB-FORMAT drive that appears on your computer. Download the 1.02.18A firmware - the one on my site has been known to work: http://chrisjs.com/PP5022.mi4 . Save that onto your sansa, and rename it to firmware.mi4. Download the bootloader as well - http://chrisjs.com/download/firmware…DSUPPORTSD.ROM . Save that onto your sansa, and rename it to pribootLoader.rom. Note that firmware.mi4 and pribootLoader.rom are case sensitive. Create a blank file called sansa.fmt in notepad, and save it onto the 16MB-FORMAT drive as well.

The files need are on that site

I googled for hours…even talked to sansa
This, i believe is foolproof

Just follow directions carefully

put all 4 files in the 16mb drive

@fafafooey wrote:

I signed up just to post this…I was near throwing my sansa away and buying a refurb…

This is the only thing that worked

I was stuck in recovery mode but couldnt do anything…

 

this is from another site…so ill post the url and paste the info

 

                    …edited to remove incorrect information & link and shorten the post… 

 

The files need are on that site

 

I googled for hours…even talked to sansa
This, i believe is foolproof

 

Just follow directions carefully

 

put all 4 files in the 16mb drive

 

 

Your instructions will not work for the Sansa Express, they are for the Sansa e200.  

I just want to thank Nitro for his firmware uploading instructions.

These were the only set of instructions that allowed me to upgrade my firmware on a Windows 2000 PC.

I bought my Sansa Express last weekend in Germany for EUR 25 without the FM radio.

With the American firmware installed, it now has a fully functioning FM radio!

My question though is: Why do they always keep out the goodies for the European market?

where can I find the version.txt file?

I bought my SE 1GB on 5/30/08. What a mistake! If only I had read this forum beforehand and knew what a Lemon this thing is. It never worked from the moment I opened the package – same problem so many others reported – menu screen frozen on the Music with earphones screen. It came already loaded with Firmware 01.01.05A2 so updating was not an issue. I called Customer Support and ran through all their suggestions which did not correct the problem. They obviously are “clueless” as someone else noted on the Forum. They eventully referred me to the Forum and told me to return the devise if that did not help. I tried every suggestion on the Forum, except buying an additional Sandisk memory card. I refuse to give them any more money. Nothing helped so I went back to BestBuy and they readily let me exchange it for another. SUPRISE – THE NEW DEVISE HAS EXACTLY THE SAME PROBLEM! I only hope BestBuy gives me a credit so I can use it toward buying something else – certainly NOT another SanDisk product. How they can continue to knowingly sell this defective product to unsuspecting consumers is beyond me. Can anyone recommend a good reliable MP3 player?

Paul:angry:

Thanks for fixing my SE:)

The Sansa Clip is good player, excellent sound quality and stability.  The price is good as well.

The Express should work out of the box, but can have trouble when songs are transferred.  Also, running Windows XP or Vista and Windows Media Player 11

improves handling on a PC (this is true for many mp3 players).  It is possible that you have run into a bad batch.

None of the above helped but in desperation I stuck and add-in microsd card into the snasa express.  It rebuilt the data base, recovered all my songs and started working again.  The really funny part of this was the memory card I stuck in was defective and would not format in the Sansa when I tried it a couple weeks ago.

You have to love reliable software.  And I will if I ever find any…

Thanks for all the ideas guys.

Yeah I’m a newbie. My 1 gb express was purchased used from my son who moved UP?? to some kind of fruit. Updated - had to do it the hard way. Been using Sandisk 2gb chips for three months. Purchased last week 2 Sandisk 4gb SDHC for less than one 2gb cost me three months ago, plugged 'em in and ran down the road. The only flaw I see is “non-replacable battery”. I already found a “cracked open the express” photo article which puts me halfway there. Does anyone know if Sandisk will sell me a battery for an express obviously out of warranty?

What issues does this update address?