Express Firmware Update Error

Not sure why we can’t reply in the announcement thread for the firmware update thread, but I’m receiving the below error when running the update:

The link to the error is below.  That was received after the update started and my player still doesn’t work.  Any help would be greatly appreciated.

I think I had the same problem as you yesterday, but I managed to fix it.  See the following thread:

is it just 2 cases of people, or are there more?

I can’t speak to how many are getting errors, but I still am. 

Thomas - I’m guessing that a soft reset is the select button and volume down at the same time, right?   I tried this while it was plugged into the computer in MSC mode and nothing happens. 

When loading the firmware update, you just copy the StMp3Rec.sys into c:\windows\system32\drivers, put the device in MSC mode and run the SansaExpressUpdater file correct?  I don’t think I did anything wrong in regards to the original instructions in the firmware announcement thread.

Actually, a soft reset is performed by pressing the Volume Up (+) and Select buttons at the same time.  I did this after connecting my device to my computer and my computer recognized the device as an STMP3600 (not a Sansa Express).  I let my computer find drivers automatically and it installed drivers for a “Player Recovery Class”.  Then I ran the firmware update utility and it successfully updated the device.

I used the automatic firmware update utility that runs in the background.  I am fairly sure I didn’t do anything wrong, so I am guessing that the data that was on my device when I first tried the update somehow prevented the update from working properly or prevented the device from starting.  Perhaps performing an internal format right before the firmware update would have cleared any bad data and prevented the problem.

I hope this helps.

When I try to run the “Check For Updates Now” from the Sansa Update icon in the bottom right hand tray of Windows, I receive a message that my player is in MTP mode even though it’s in MSC mode. 

It seems as though this firmware update was supposed to fix this problem.  I wish it was working for me.

Update:  I get plugging away at it and somehow got the player to be recognized as a new hardware device just like your post mentioned.  I followed the steps and am listening to my player again.  Thanks for the help!

I tried the firmware update - wont work because the express wont even turn on.  It has a little blue square in the middle of the screen.  Its showing up in my portable media device driver file.  But when I open media 10, it cant find a device - and like I said the express wont even turn on.  Im assuming the firmware update is uselesss unless the player will turn on - I bought this thing at and my 30 days are up - it broke on the 32 day (convenient) does this mean im out of luck with the thing?? Sounds like Sansa isnt very cooperative - im a bit worried I just threw my money away…any help??

I had the same problem, complete with the strange blue object in the screen.  Try the “revised debricking procedure” in my second post in this thread:

I think you can probably get your device working again.