Problem while trying to update Firmware.

I’m a owner of an Sansa Express, And about the first thing i did was going to the forum for Sansa Express and downloaded the new Firmware and followed the guide on how to install it. I started SansaExpressUpdater.exe and a window poped up and were saying that i shouldn’t disconnect my device etc. So i left my computer for a while and came back and nothing happened, I waited for almost 2 hours before i decided to disconnect my device and turn off the updater.

And after that it hasn’t worked at all, When trying to start it shows the SanDisk logo and turns off. Tried to install the Firmware again but without success.

I’ve asked for support in the Sansa Express section but haven’t gotten much help so far.

So what do you think i should try? I was thinking i could try to format the device so it wipes everything, including the firmware. Hopefully it could work, But i don’t know how to.

Soon i’m throwing this piece of plastic in the garbage and buying a new player of another producer.

Im right behind you - its so frustrating - my Sansa is on an Express course to the trash as well.

If you haven’t figured out a solution and still wanna try you should take a look at this thread:

I’ve gotten some answers in there that helped me out alot!

Good Luck!