Sansa Express

Hi there,

I’ve got a huge problem with my Sansa Express (1GB).

I wanted to update the firmware to enable the FM function (which is disabled with European firmware) by using the American firmware. So I followed this instruction:

This update completely failed now: After pressing the (-) volume button while plugging my Sansa in, I formated the device so all original folders and firmware files are gone now. Well, that was the intention. But now the firmware update won’t work. By clicking on the SansaExpressUpdater .exe file, the following window pops up


and nothing happens. Could it be that the Express Updater does not work on Windows 7?

Then I tried the online firmware updater (Sansa Updater). But after all folders and files on my player were deleted, the online Sansa Updater does not either recognize my device anymore. It is now shown as a ‘normal’ storage device like a hard drive in Windows 7.

So now, nothing is working anymore. I cannot switch my player on anymore nor reset it to the original configuration because there is no recovery software available apart from the firmware update process which does not work.

It would be very kind if anyone could help me or tell me how to recover the original configuration of my Sansa Express. Sorry for my poor english.

Best regards

Well, I have the exact same problem, and I haven’t had any luck finding a solution… help anybody?

Hi kyrnn_bruce,

what kind of OS do you use? Windows 7?

I finally ‘revived’ my Sansa Express this weekend by installing the firmware on another system that is running Windows XP, without any problems. Seems to me that Windows 7 does not recognize the StMp3rec.sys file correctly, which you should move to your ‘system32/drivers/’ folder. Do you have any opportunities to try the firmware update on Windows XP?

Anyway you should follow Method 2 which is described on the bottom of this description. Method 1, the online firmware update method with Sansa Updater failed everytime I tried because my device was never found.

If you have further questions, go on. I really would like to help to make others happy as I am after my Sansa Express was finally revived.

Hi SansaGorilla and krynn_bruce

Just wanted to share with you my experience, I accidentally ‘bricked’ my Sansa Express during the firmware upgrade process Method 2 (because I did not understand what I was doing and the instructions are unclear) and I, too, was only able to get it back working, by doing what you did, on my other half’s machine, which is running XP - and it still took a great deal of persistence with that process of plugging it in while holding down the volume button - that bit was very hit and miss, to get the right screen to come up - and that also only worked AFTER we’d done a hard re-set on the sansa express.