sansa express firmware update using zipfile method fails with sansa updater hang after reformat step

I am attempting to update the firmware of  a sansa express

I was unable to use the regular updater because of the windows x64 limitation.  so I tried the zip file method. I downloaded the zipfile as suggested in the thread on updating the sansa express firmware; I put the driver in the proper directory and  I was able to put the unit into sansa recovery mode by inserting the player while holding the volume - button and loading the driver; and the updater ran through the format portion and sat there.  now, nothing can be done with the unit at all.  it is registering as a 1GB storage device and nothing more.  I subsequently found a “new” updater, with no 64 bit limitation, not mentioned in the above referenced thread, but it won’t recognize the unit, since it has been wiped clean.  What can I do now? Isn’t there a file I can load onto the unit manually? Any help you could provide would be appreciated, since the only method everyone seems to be referencing depends on this zipfile’s updater which does nothing on my machine.

thanks in advance for any help you might be able to give.



2.2 GHz 3GB

sansa express 1 GB with no expansion card

Is there something else I did wrong that is keeping my question from getting an anwer? If I broke some rules I apologize, I am a newb to this forum after all.  But I promise I did search extensively to find an answer before I asked my question…please please if there’s anyone out there with the real firmware files (and not an installation package) I could really use some help!



How 'bout this?

This knowledgebase article describes both the Updater as well as the manual install method with a link to the latest .zip file download.

Note you have to un-zip the file first; you can’t just copy the .zip file over to the decvice and expect it to work. :wink:

thanks for your reply.  your link leads to the method that i used, and followed to the letter, with my computer just hanging right after the reformat step.  I left the computer, even though it said the updater was using none of the computer’s resources, for a full day just in case it would do something but it didn’t.  Subsequent tries resulted in the same thing happening.  I could get the updater from the zipfile to run right up to the format step, where it would say “format complete” and then the updater stopped.

After that I found the newest updater that works on my 64 bit machine but it won’t recognize the unit because it’s been formatted.

I even tried transferring the unzipped files(except the updater) to the sansa express but this gave no results.  I’ve since reformatted the unit.

I guess i’ve tried one too many times because now a format won’t even complete on the unit and I was getting an I/O error when i try to run the updater from the zipfile.  as it currently stands, when I run the updater from the zipfile it says it cannot open (I redownloaded to make sure the file wasn’t corrupted).

when i tried to run a reformat from cmd.exe i get a hang at verifying  the size of the drive or another error.  I can’t tell you what the error is because i can’t reproduce it because NOW i can’t get F: or G: to even show up.

the only things that happen now are 1) i can insert the unit (even with - pressed) and stmp3600 shows up in devices (sansa recovery no longer does) and 2) the reset works (holding the + and select keys) and the unit will behave as if it has been removed and reinserted when i reset.

Since i got a response telling me to do what i already did, namely use the zipfile method (because the updater method wouldn’t work on my 64 bit machine), I must conclude that A)I didn’t ask my question right or the person who answered would have known i already tried that and B) I’ve probably screwed up the unit so badly it won’t even work as a hockey puck.

My third assumption I’d love if someone could disprove, but I have little hope of that: that there is nothing further I can do and I have to give up.  I hate giving up.  I hate throwing away hardware. 

Thanks though, for answering, even if you couldn’t help I really appreciate the time and effort.

I had this problem, too.  I’m no expert, but I think you’ve done what I did - inadvertently ‘bricked’ your device - so it isn’t being recognised as an mp3 device anymore.  I finally got mine ‘back’ after I asked my husband for help and he installed the firmware  from his laptop, which runs XP - mine runs Windows 7 and I had had no luck at all.  That business of holding in the volume button while plugging it in, is very hit-and-miss, and it was, even on the XP machine, but it did finally work.  We also cut a strip off an old credit card and pushed that gently into the memory card slot of the device (not sure whether that did anything, but we read that on another thread).  The one thing that I think made a difference was doing a hard reset on the device before installing the firmware from the XP machine (this from the user manual):  To perform hardware reset on the Sansa Express™ device, press and hold the Select button while pressing the Volume Up (+) buttons simultaneously.

Also, take a look at this thread, which is about the same topic: and suggests that the  firmware updater doesn’t work properly with Windows 7.   Good luck!

yes…the trouble is updating with windows7 …with xp…update works fine…I already solved once…

I have Sansa Express already 3years …and it worked fine till now…reliable sound quality, good menu design.i’m pleased besides my other 2 mp3players…I’ve got only once problem with the sansa …the pc suddenly did not recognize device…you know stmp3600 driver…but updated manually the firmware …and I fixed the problem that time…now…my computer is recognizing my device ok…same Mtp protocol…same read/write files on player…ok…noproblem…but  physically…Sansa Express Display cannot start…device just wont start…whats the problem?

@mickjagger37 wrote:

Sansa Express Display cannot start…device just wont start…whats the problem?


Dead/worn-out battery?

maybe… but I’m not sure… because I can use it with my pc …read/write files/charging the battery… as usual… just when i unplug device from my pc and turn it on sansa express…the blue display doesnt appear anymore…strange… I just loaned to one of my friends for a couple of days…i dont know what he did with the player …I have two more players… but want to save this one…sound quality is awesome on sansa express  :)