Sansa e250: Frozen after Rockbox install 'Scanning disk'.....


I just installed rockbox using the following instructions: on my sansa e250 mp3 player.

I chose the version ‘1’ e200 build (not the version 2).

When I took my USB cable out it rebooted as expected, then came up with
‘Scanning disk’ message. I searched some forums and apparently this is normal for a few minutes. Mine is still like that 8 hours later.

I’ve tried taking the batteries out and resetting, same msg.

I’ve tried replugging it into USB port, it doesn’t recognise the player and same msg remains.

I’ve tried resetting it by holding power for 15 seconds and then holding the record button. A message comes up about bootloader for a split second then same message returns.

Would appreciate any help!

What version player do you have, a v1 or v2? You can’t just arbitrarily choose one or the other. Just as there are different SanDisk firmware versions for the different hardware version players, there are different Rockbox builds too.

Your linked-to ehow instructions also warns against this under Tips & Warnings:

Be sure to download the version of Rockbox intended for the Sansa player.

You should probably format the player, erasing everything, check your firmware version to verify whether you have a v1 or v1 model player, then install the appropriate Rockbox build.

Oh, and by the way . . . Rockbox has an Installer Utility that not only makes installation a snap, but also guards against installing v2 firmware on a v1 machine (or vice-versa). You don’t have to jump through the flaming hoops suggested by the out-dated information on