Sansa connection problem with Windows Explorer

Our e270v1 and e260v3 quit showing up on Explorer after I installed a Microsoft web cam on the desktop (I hate you, Bill Gates).  Switching the USB mode to ‘MSC’ at least made the stuff on the SD card visible, but not the tunes on the built in memory.  I tried plugging in to a different laptop and that still worked like it’s supposed to. 

Any suggestions?

Does the webcam plug into a USB port? Sounds like you might have a conflict. You should be able to resolvve it in Device Manager.

Got back to messing with the missing files on the main memory.  I typically just drag music to the Sandisk w/ Windows Explorer in XP.  I can see all the previously loaded folders on the SD card, but cannot see the old stuff on the main device.  Both the main and SD devices show up when connected, and the built in memory shows up as nearly full, but no other info.

I tried dragging some more tunes to the main w/ Explorer and it shows up like it did before.  Just can’t find the old.

I also tried connecting with Media Player 11  and got the same results - finds the SD tunes and not the old files on the main.  Other than deleting the stuff on the Sandisk and reloading, any suggestions?  Is this a Windows thing? Based on other posts, maybe I should reinstall Media Player 10?? 

It’s a Microsoft thing, actually.  Files transferred in MTP Mode will not be visible while in MSC Mode , making for “invisible” files when using Windows Explorer.

The culprit is the system registry of your PC.  When it enumerates, or queries the device upon finding it on the USB port, the Sansa is ignored.  Why would your PC do such a thing?  Simply, the registry is the computer’s “cheat sheet”, telling it what to do with the device.


When you installed that webcam , the registry entry was lost in translation, so to speak.  Most often, uninstalling the connected sansa, then reinstalling automatically upon reconnect, will fix the problem.  Windows is seeing the device, and then runs to the cheat sheet next, rather than performing a reinstallation.  It looks like the device is “broken”, since it suddenly isn’t recognized.

Here’s the most important point:  the Sansa will happily communicate in either mode, and will display all music files regardless of mode.  From the computer, you can’t see both modes at the same time.

Where does Windows Media Player fall into this equation?  Simply, MTP Mode , where the Sansa is recognized as a media player or portable device rather than a flash drive, is part of WiMP10 and later.  Please note that you don’t have to use WiMP directly in MTP mode, since MTP is possible through Windows Explorer too.  In MTP, you’ll see the Sansa lister under “other” as a media device; a double click opens the device into Internal Memory and External.

MTP is a virtual mode supported by Windows Media Player, allowing the transfer of protected content to your device.  Since it’s seen as a media player in this mode, you can also do some cool things like generate playlists via a right click, and album art transfer is automated too.

To reestablish MTP “connectivity” or communication (would we say “communicationivity”- some computer terms are simply crazy), manually select MTP on the Sansa via Settings > USB Mode > MTP, and plug in.  Open the Device Manager via a right click on My Computer, then select manage , then open the device manager.  In the listing, the Sansa should be listed under “portable device”.  Double click, or right click on it, and select uninstall.

How simple was that!  Unplug the cable, and try plugging in again after at least 30 seconds, allowing the PC to make changes.  The device should now show up in Windows Explorer like it used to.

Many users opt to simply use MSC Mode exclusively, since it is what I’d call a manual, or direct mode.  This mode works great for drag and drop of unprotected mp3 or wma files.  If you have DRM protected media, MTP is needed.

Bob  :smileyvery-happy:

I have a View. USB options are either MSC or Automatic. In either mode, no data shows up in my Default Sansa folders (Music, etc), just the folders appear from internal memory.  Therefore, I cannot edit my files in internal memory. I have tried forcing the mode, but does not help. Files show up fine on my added memory card. I am not sure if “automatic” is truly switching mode to MTP. I do not remember which mode I was in when I transferred files into internal memory in the first place. Potable device does not show up in device manager.

More likely why your Sansa View is not recognized under MTP mode is because your Windows Media Player has been rolled back to older version. For the Sansa to be recognized under Portable device you should have Windows Media Player version 10 or above.

Automatic means the Sansa will try to connect under MTP mode first but if it is unable to connect under that mode, it will automatically switch to MSC mode. More likely your songs were transferred under MTP mode (portable device) but because MTP problem the sansa is no longer recognized under MTP mode on your PC. Easy fix is to format your Sansa and just reload the songs back under MSC.

This is a fairly new Sansa, my second.  My XP system and the Windows Media Ctr. suddenly doesn’t recognize.  I have Napster songs I want to load in.  Eric