can't see the files on my laptop anymore

Hi, I’ve recently had to wipe my laptop cause of a virus and now its up and running again I can’t see any of the music

I put on my sandisk player when I open it on my laptop. I can still see it on the player but not on the laptop!

Really annoying as I can’t delete it off the player as I’ve no longer got it on my laptop but can’t see it to transfer it back onto

my laptop :cry:

Please help!

Thank you!

Try switching the USB mode on your player. Files added in MTP mode cannot be seen or accessed on your computer while connected in MSC mode, and vice-versa.

Don’t use the Auto setting.

It sounds like you may have lost a communications protocol when reinstalling your operating system.  I’ll hedge my bet that you more than likely are running Windows XP on your system.

Out-of-the-box, Windows XP has Windows Media Player 9 included, which does not support the MTP protocol.  Assuming nothing has been changed on your Sansa, as far as the USB mode selection options are concerned, you have more than likely lost MTP.

Let’s try two simple experiments (no beakers or test tubes required).  First, open Windows Media Player and click on Help > About.  If you have WiMP 9 or earlier, you can simply upgrade to WiMP 10 or 11.  (WiMP 12 is part of Windows 7)

Open a Windows Explorer window by clicking on My Computer.  (If WiMP is still open, go ahead and close it for now.)  Let’s see the connected mode.  If the Sansa is listed with a drive letter assigned , like E: it’s in MSC mode, where the Sansa is addressed as a mass data storage device.

If the Sansa has no drive letter, and is listed as a media device under “other”, you’re in MTP mode.

Click on your Sansa and see if your music is visible, in the Music Folder.  If not, we simply need to either change the USB mode currently selected, or the cahnge has been made by a difference in Windows Media Player.  This is the confusing part, so I’ll elaborate a little bit.

First, unplug your Sansa and go to the USB Mode screen.  This is under Settings > USB Mode or Settings > System Settings > USB Mode depending upon the device and firmware installed.  Of particular interest is the Auto Detect setting.  In this setting, the Sansa will connect in MTP mode if the computer supports it (meaning that the MTP porting kit or WiMP 10 or later is installed).  If you upgrade the media player, or if there was a problem with MTP prior to the repair, the Sansa will switch over.

Files transferred in one mode are invisible while in the alternate mode.  This is why it looks like your files are missing, despite their still being on the player.

To do away with this confusion, simply select MSC or MTP manually , so you will remain in the chosen mode.  Why has SanDisk made an auto-detect function?  This is simple.  Care to guess the percentage of users that simply plug in the device and sail on without ever wondering about which mode the player is in?  Auto Detect is designed to establish a connection, based upon the capabilities of the host computer.  If you happen to have a Mac, or a PC using Windows, or a linux distribution- be it Red Hat / Knoppix / Ubuntu, or any similar version, the Sansa just connects (“mounts” in linux / advanced user parlance).


Using Windows Explorer (My Computer in Microsoft_ese_), if you don’t see your music, switch to the other mode on the device.  In your case, if it’s like I think it is, this was most likely MTP.  Once you upgrade Windows Media Player, you’ll be able to sail along again.  Note, for those reading this, that WiMP can manage your device regardless of the chosen mode.

Ah, one final point.  WiMP gives us MTP, a virtual mode, even if you never use Windows Media Player to manage your device.  The protocol supports drag-and-drop functions using Windows Explorer, so many folks don’t even know that they’re in this mode.  MTP does a lot of little things in the background, my favorite being playlists via a simple right-click.

Hope this helps!  Let me know if you have any questions, or if you’ve solved this puzzle on your machine!

Bob  :smileyvery-happy: