My Computer can only find 1 song on my Sansa e260 v2, but there's about 600 on it

When I open the folder in My Computer/Sansa E200P/Music, it only shows up one MP3 file, but the player has about 600 songs on it. I’m guessing it’s a problem with the computer, because they showed up fine on my old laptop. I have tried doing a search for hidden files and folders, but it only comes up with that one song still. Computer is running Microsoft Windows XP Professional version 2002.

Any help gratefully received!!



Message Edited by Joram on 06-05-2010 01:29 AM

Switch your USB mode (in Settings). Chances are it’s been in the default Auto Defect mode and is connecting via one of the 2 options (MTP & MSC) on the old laptop and the other when connected to the current one.

Your computer can only ‘see’ the files added in 1 mode at a time.

Windows XP was shipped with Windows Media Player 9, which does not have MTP (Media Transfer Protocol) capabilities yet.  Using Auto Detect, the Sansa will connect, but since MTP is not available, it switches to MSC (Mass Storage Class) as a backup.

MSC mode is where the Sansa is addressable as a flash memory device.   You’ll also see a second drive, this is the expansion port of your e200.

So, why is your music missing?  It’s an apparent oddity of the design, but files transferred in one mode are “invisible” while in the alternate mode.

Upgrade your Windows Media Player  to version 10 or 11, and you will have MTP capability on your second computer.  MTP is needed to transfer protected media, such as subscription services, audiobooks, or any file with DRM (Digital Media Rights) embedded.  MTP does some cool things in the background, like album art and song rating information.

To update WiMP 9, simply open the player, click on Help, then go to Check For Updates.

SanDisk built Auto Detect capability into the Sansa, as it assures the device will connect more readily.  You can, if desired, select MSC or MTP mode manually on the device, by going to Settings > USB Mode.  You mentioned that you have a v2 device.  To confirm this, the quickest way is by the start up “splash screen”.  If you see the SanDisk logo with a reflection below, and a blue sansa logo below that, you have a v2.

There are quite a few refurbished v1 devices out there that say “v2” on the back.  This is because the rear cover plate has been replaced with a shiny v2 one.  The two versions have different central processors, and must be tackled differently when it comes to firmware upgrades or fixing glitches.  To confirm the version, on the device, go to Settings > Infoand read the top line.  If the firmware build number begins with 01, you have a v1; if it begins with an 03, you have a v2.

If you do not have the USB mode option in Settings,  you have a v2 with firmware version 03.01.11.  This initial version was released as an MTP machine, solved by upgrading the firmware.

Bob  :smileyvery-happy:

Thanks!! that’s done it :)