Sansa Connect Installation Problem

I’ve been reading over the threads to see if my problem has been asked before, but so far I haven’t found anything. I’m having problems with my Dell/XP system finding my whitebox Sansa Connect. The first time I plugged the player into my laptop, it looked like it was going through the sync process fine and then it just stopped. Now when I connect the Connect, it isn’t recognized on the task bar and WMP10 says it can’t find a player. Looking in the Device Manager there is a Sansa PMP that is recognized there with an Exclamation point beside it. 

Clicking on it, it asks for a hardware launch and the MTP folder dialog window comes up. Files are transferring and then it stops with the following error message:

Cannot Install this Hardware

There was a problem installing this hardware:

Sansa PMP

An error occureed during the installation of the device

A service installation section in this INF is invalid

click finish to close the wizard.


The device works on my coworker’s laptop…as at first I thought the whole thing was buggy. And I’ve just reinstalled my laptop’s motherboard.

So I’m just trying to figure out what to do next. I really am beginning to hate that I bought this player.  

Read this thread:

This solution appears to work for Sansa players:

“Installing this framework worked for me. My 2GB Sansa Express worked fine out of the box, but randomly started giving me the same error. After installing this, not only did it work again, but it now shows up as a portable device instead of just a removable disk. Bonus!”