Sansa Clips and Napster To Go

Hi all,

First I would like to start out by saying that I have done a topic search on this topic, read all the suggestions, updated my drivers, formatted my Clips and they still don’t talk to my Napster account. I even tried installing the Rhapsody- BestBuy Store application. That application doesn’t recognize either of my Clips either.

I have made sure that they are in MTP mode as well.

I have 2 clips: 1- 2G from Radioshack that was recieved for Christmas '08

                    1- 4G from Best Buy that was recieved today.

I have fired off an eMail to Napster support as well, but haven’t recieved a response…

So… anybody else have any ideas?


Update your Windows Media Player to WMP11

I just picked up a SanDisk clip for my Napster To Go - and it doesn’t recognize.  I did as the previous poster suggested and upgraded Windows Media Player to version 11… and it wrecked my Napster!  This is VERY frustrating.

It’s me again.  I have downloaded the MTP kit for Windows, checked my driver in My Computer (my Clips shows up as a disk drive for some reason!!).  My firmware on my clip has been updated to .30… let’s see… what else…

My Clip is set to MTP…

I feel sure that the problem is not with Napster, but with the fact that my PCs (yes, I’ve tried two of them) is showing the clip as a disk drive.  What the heck dould I possibly be doing wrong.  Help!