Dead to the world and no longer recognized by Napster

Hello, I have a Sansa Clip Plus 4gb that after being used less than a couple of months has gone dead.

Tonight I recharged it through a USB port, as always, but this time the display shows a completely charged battery until I disconnect the charging cord.  Then it shows low battery and shuts off.  Also the Sansa Clip is not longer recognized on the Napster web page as being plugged in and ready to transfer tracks. 

The unit had worked fine and has not been dropped or abused in any way.

I was hoping to be able to hit the re-format button, but the unit won’t stay on long enough to allow that.

I tried to download and use the Sansa Recovery program but it wouldn’t complete the install process.

This is the second Sansa Clip that has gone down in less than 2 months. 

Does anyone have any ideas about this?  The fact that the unit is not longer recognized by Napster leads me to believe that maybe it’s not a shot battery?

The unit of off warranty as I purchased it to use as a back up.  My other unit has a shot power button, which I understand is not fixable.  SHEESH!!!  Hope someone can help.