Sansa Clip Zip wont work.

Hi guys,

15 days ago I purchased this device and now It wont work, It doesn´t turn on and When connected to a Windows 7x64 its detected but says that the device needs to be formatted in order to be used. The computer detects a 30 mb FAT partition but cant be formatted.

Holding power button for 30 secs dont work.

Can something be done before sending it to customer support?.

Ii sounds like it’s a bum unit. You can contact SanDisk directly for a warranty replacement, or based on when you say you bought it, you might consider retruning it to your dealer which could be faster.

If contacting SanDisk, faster to do so by phone rather than email support.

I just purchased Clip Zip SN this evening at Best Buy. The firmware version is 01.01.21A. 

Problem: The sample stuff plays very well. The device powers up when connected to my laptop but it is never visible in My Computer under the C and D (DVD) drives. I’ve rebooted  my laptop to rule out an on-board USB issue and the Sansa is still not appearing. Bum unit?

What is the player’s USB mode (under Sysytem settings) set to?  If you set to MSC mode, does that help?

Note:  a computer only will see and show songs on the player that were transferred to the player under the USB mode that the computer then is connected under.  The sample songs were put on the player under USB MTP mode.  Thus, when you connect to your computer under USB MSC mode, the computer will not see them.  Solution:  set the player to MTP mode, copy the files you see to your computer and delete the songs on the player, disconnect the player and set it to MSC mode, and transfer the songs back to the player.   

MSC mode seems to function the most trouble-free, and is recommended (by me)–but if you play DRM music, you will need to use MTP mode. 

I tried Auto, MSC and MTP. No change. It charges, but the OS never sees the device at all. There are no messages about new conenctions or “device is ready to use” and no drive letter appears in My Computer. Thanks!

Drive letters only appear (2; one for the player and the other for the card slot) if the player is connected in MSC mode. In MTP (or Auton Defect), your computer sees the player as an “audio device” which must be managed and no drive letters are assigned.

Sometimes, Windows can get “stuck” and it can work to start over, by going into the Windows Device Manager and de-authorizing the Clip drive, unplugging the player and then replugging–this forces Windows to try making a brand new connection. 


  The device never appeared on the USB . I returned it to Best Buy tonight for a replacement and the new one connected and became immediately visible! ALl is good!



Great to hear!    :slight_smile:

I’m having this same problem.

I’ve tried holding reset for 5+ mins.

I’ve tried connecting in different modes.

I’ve tried disabling/uninstalling the sansa firmware on the PC.

I’ve tried letting it sit alone for 3 days.

I’ve tried charging it on a wall charger for 4 days.

What do?

Manually reapply the latest firmware–see the firmware sticky thread above.

If that doesn’t work, reformat under the player’s System settings (note:  this will erase your user content; tansfer anything you want to save to your computer first).

That’s the thing though.

I can’t turn my device on at all. That means I can’t access the settings nor apply firmware.

What do?

Sometimes, the battery charge is so low that the player can’t turn on.  It sometimes can work to recharge the player and leave it charging for a few days–the “trickle-charging” can be enough to get the player over that barrier.

I believe he said he already left it on a charger for 4 days. That should be sufficient.

This pretty much explains my problem and diagnoses what has happened to my device.

If that just happened randomly without you doing anything to cause it, a dead flash memory chip would be my guess.

Any fixes for it? Its either that or my FAT is corrupt

Assuming what you said above is accurate, I doubt it can be fixed.

@tapeworm wrote:

I believe he said he already left it on a charger for 4 days. That should be sufficient.

Yp–that’s why I wrote, “a few days.”

You might want to contact SanDisk Customer Support at this point–phone is best–and see what they offer.