Sansa Clip Won't Recognize my PC

Ok Here's the story, I bought this Sansa Clip 2GB  like 2 years ago and used it perfectly fine for a couple of weeks, forgot about it and lost it, and now I find it and I try to connect it to my computer and it won't recognize at all, I have Windows 7, yet I know there are no drivers for this at all. I have also tried VMware Workstation 7 and installed Windows XP SP3, it won't recognize in that either, all the drivers are up-to-date on my Virtual Windows XP, I updated them all till no more updates available, did so much research for this and my firmware first of all is so dam/\/ old, V01.01.11, I have tried MSC Mode(Turn off Device, Put on lock by pressing down till you see orange on the side, hold center, plug with USB while holding center button) but nothing happens at all, There is no MTP Mode or such mode on my Clip as there is no option and can only appear if I update the firmware, well I can't update firmware if it can't even recognize... I tried installing WMP 11 on XP but still no luck, tried MTP Driver from Microsoft, still no luck at all, Everything I tried still didn't work, I even tried it on my old PC which has Windows 2000  Professional  which has USB 2.0 drivers and MTP drivers and no luck, checked or at least tried with many USB cables no luck, I think this is the most ridiculous MP3 device I ever invested on, I will just end up buying a new mp3 player if there is no solution for this piece of crap.... Don't get me wrong, it was an amazing device then, now indescribable....

Here’s a trick that sometimes works: without connecting to your computer, turn your Clip on and format it from its own settings (note: this will erase the content on your Clip), and then try to connect to your computer either directly or using the “force MSC mode” trick you note above (using the hold switch and center button). Again, this will erase the content on your Clip, and so do not try this unless you’re willing to accept that this may not work and you may not have your content still on the Clip. For whatever it’s worth, I haven’t had any issue with connecting my Clip to my Win7 computer.

Well the thing is I already formated it and tried that option so many times, also this sansa is like so old I barely even updated it when I got it, I  tried many options, i Know i got it working on my old PC that had XP on there and at that time it worked, now I dont have any XP PC, I might install XP inreplacement of my Win 200 pro and see, I mean, it could be that virtual OS may be causing it as well? But it should recognize on Win7, well I’ll give it a go and let you know.

Well I tried and it still didn’t work. Looks like I’m out of all options…

same happens to me … try everything … still don’t work … i stay 1 year and half without using my sansa 2gb now i try any differents pcs … try everything … when i plugging on my pc he still connected but didn’t charge or i can use … win 7 show me the error “USB device not recognized” so i can’t put musics … so didn’t work … i know is the driver and i go on microsoft page and show me that message “This product installs automatically without extra software.” but still don’t work … try win xp … same problem … anybody can find the way to get this driver?!

Thank You

Vinicius

I am no expert on this, but I fixed it.   After a Windows update, my computer no longer recognized (Windows Explorer did not show it)  my Sansa Clip although it did sound like it was connecting.  Figuring it was the update, and probably the drivers, I searched the blogs to find out how to download the drivers.   I found there are lots of people trying to sell you something, and got little help from Sandisk.   But, one of the blogs mentioned going to my own computer Device Manager, which I did, and Viola!  There was the Sansa Clip.   Still not knowing what I was doing, I first right clicked on it and told it to find the drivers on the web, but it locked up.   Then something came up about downloading the manual from Sandisk, and at first I didn’t, but what the hell, so I downloaded it and that did it.   Windows explorer now shows the Sansa Clip and I am back in business.  So - go to Start - Control Panel -Hardware - Device Manager -  Sansa Clip (if your device does not show up - then you have a different problem) -  right click or left click and explore . . . good luck - aaa