Sansa Clip not recognized anymore

Hi everybody.

I have a serious problem with my Sansa Clip 2GB.

When I bought it everything worked perfectly for about a month or so. But then, suddenly, the player wasn’t recognized anymore by Windows XP.  I reinstalled Windows (for other reasons), updated to WMP 11, but nothing worked.

I also reformatted the player, then set it to hold mode, pushed the middle button and plugged it in- nothing happens.  No “windows-device-plugged-in” sound, no message, nothing. The only thing that happens is that the Clip starts charging its battery.

So, what else do you think I can do (apart from sending it back?)

Waiting for your advice,



I have exactly the same problem! Because I sync my Sansa Clip with my laptop, I thought it was only a problem of my laptop. I reinstalled Windows XP, too. But it doesn’t matter. Then I tried to sync my clip with my normal pc, but nothing happened either.

Is this a general problem of the clip?

Hope you can help me…


have u ever try to read the manual? look for it, search on the "#$%&!! usb config… 


Thanks for that helpful bit of advice.

Believe it or not, that got my Clip working again.[/sarcasm]


just let the battery die (make sure it will not turn on at all) and then plug it in and it should work :smileyvery-happy: