Sansa Clip+ with a mac HELP!!

Okay so I’m brand new to all this. It’s my first me player ever, having only ever used ipod’s etc. Got it because of the ability to have more music on the go due to the expandable memory slot. So I bought a 64GB card to go with. This is what happened:

  1. when copying files to the card after a certain point it will not copy any of the files onto my card from my mac. All files are MP3 and the card is FAT formatted. Why is this happening?

  2. Any files on the ŠD card will not play on my clip. It load the song then freezes as if about to play the song.

  3. Tried loading specific tracks just onto the clip which seemed to go fine. Until I disconnect the clip properly at which point this clip now boots up the little sansa flower twice and then the refreshing your media screen and freezes 2/8 of the way through.

Am I being really silly? Do I need to be more patient with it? What’s going on?

Macs can tend not to play well with non-Apple devices.   :frowning:

Sometimes recommended:  using Internet freeware Hidden Cleaner to transfer files from a Mac to a non-Apple device, such as the Clip.  Among other things, Hidden Cleaner will clean away Mac “ghost” files that a Mac will place on a device, which otherwise could choke the device (that might be the issue you are having).  You might try that–hopefully, you will be able to start the Clip up fully so that you can, at which point I would clean away everything on the Clip (you can format the Clip under its System settings–this will delete all the user content (music, books, etc.) on the player) and start anew.

First of all, welcome to the not-getting-ripped-off side of the music player universe. I’m amazed at how much people play for doPi players with such limited capacity.

Apple’s strategy is to stay incompatible with the rest of the known universe. So you have to build some bridges first. I know this looks long but it’s basically a one-time setup for a simple thing. You can thank Steve Jobs for the annoyance factor.

Anyway, it sounds like the Clip is getting files or a format it doesn’t understand, and it’s choking.

I’d suggest nuking it and starting over.

Take out the microSD card and see if the unit will boot up.

If it will, go to Settings/System Settings/USB Mode and make it MSC. MTP connects to Windows Media Player and Auto Detect just flips between the two modes. With a Mac you’ll always use MSC, so make it official.

(If it won’t boot up but your Mac can still read it, delete everything you have put on it and empty the trash before disconnecting.

With luck, that will let you restart the Sansa.)  

Go to Settings/System Settings/Format. That will format the Sansa’s internal memory to remove everything you’ve put on.

Also, format the 64GB card to FAT32  (you just said FAT, it has to be FAT32). Are you sure it’s a working card?

OK, now reload with  well-tagged mp3s.

The Sansa reads the tags of the mp3 files to list Album, Artist, etc.  Its favorite tag version is ID3v2.3 ISO-8859-1, but it will also read ID3v2.2, which is what my (Windows) version of iTunes puts out. ISO-8859-1 is the way Windows encodes the alphabet. Macs use UTF, which sometimes gives you funny characters onscreen or, worse, makes the unit choke.  And I don’t think Sansa has caught up with ID3v2.4 yet in case your music software is doing those.

Do a little research and find a free Mac tag editor that can change the tag version  (there’s probably no need to pay for one).  Just Googling, I see kid3. 

I just downloaded it and the Windows version has ID3v2.3 ISO-8859-1 as a default. But look in Configure kid3 to check that on your Mac.

iTunes also does Track numbers as 1/12, 2/12, etc. Sansa prefers, 01, 02, 03 and, unfortunately, will play 1/12, 10/12, 11/12, 12/12 before 2/12. kid3 has a Number Tracks under Tools.

This sounds like a PITA but it’s basically a five-second operation. Start kid3, go to the album folder, highlight all the files, Number Tracks with 01 as the first track.   Bingo, they’re renumbered and ID3v2.3

Do that with each album before loading the card. Good tags = a happy Sansa.

There are more potential tag problems. Some people load album art into each track, and the Sansa can choke on a giant image. If you’re still crashing, you may need to find another tag editor to get that art out. 

And one more caveat. 64GB is a whole lot of storage. The Sansa has a size limit on its database, the list of information from the tags, which is basically a text file (MTABLE.sys). If you have a lot of little files you are going to max out the database and it won’t display everything. I have a 32GB card filled with mp3s at 320kbps and it shows them all. But if you were using the crappy iTunes default of 128kbps, plus a card double the size, you’re probably going to max out the database.

The solution to that is the alternative open-source firmware, Rockbox, at But that’s another post. First, nuke your Clip+ and get it working again.  

You can also reload the Sansa firmware to make sure you have the latest. You can get it from this thread:

Download the .zip file, unzip it, drag the folder onto the Clip+ root directory (the drive letter), disconnect and the firmware will install itself.  You’ll have to go to Settings/System Settings/USB mode again and set it to MSC.

1 Like

The only thing I could add is that not all 3rd-party software programs will properly re-format an SDXC (exFAT format) to SDHC (FAT32). I would try (if you haven’t already) the SD Association’s SD Formatter 4.0. There’s a MAC version for it. GUI Format also works, but I think that’s a Wiondows only program.

As far as I’m aware I formatted it to FAT32 or at least what the internet tells me is the equivalent with mac. 

I have to admit, I’m finding your instructions a little bit difficult due to the technilogical jargon. 

When I went to download kid3 it is a zip file which automatically unzips on my computer however I can’t figure out what to do from there. I think I’m problem being really obtuse but can you please break this down a little bit simpler for me as a first time person who has no idea what ID3v2.3 ISO-8859-1 etc is? 

I’m not working on a windows and have no access to windows so I need to know what to do on a mac.

I’ve nuked my sansa and it’s not booting up okay (thank god) so I’m just stuck at what to do next.

Do I basically need to figure out how to ‘tag’ my MP3’s?

Thank you for the help.

When you say you nuked it, did you go to Settings/System Settings/Format and format it? Or have you taken out the card and removed all of your own files from the internal memory?

If it’s still not booting up, it could be defective. You can call 1-888-SANDISK to see if they can help you or if they will replace it under the warranty, which is one year.

The Mac version of FAT32 seems to be MS DOS (FAT). Is that what you used?

But anyway, leave the microSD card out of the unit till you get it running.

Sorry about the tech talk. ID3 tags are little bits of text stuck inside the mp3 file. They tell the unit Album, Artist, Title, etc. Unfortunately, they are not standardized and there are many versions–ID3 versions. doPi players like a different version than Sansa.

Anyway, I’m not sure you have installed kid3 or just unzipped it. In the file folder you unzipped there is probably a DMG file to install the program in a Mac. Here’s a pretty good explanation (in GIANT print, what’s up with that?)

When you have a kid3 icon on your desktop, open it. Look for a little wrench symbol or click Settings and Configure Kid3. If the Mac version is like the Windows version–not guaranteed, but let’s hope so–you’ll see a tab that says Tag 2 and in that tab you’ll see

Text Encoding, which should be ISO-8859-1


Tag Version which should be 2.3.0

Save those, close configure, don’t ever think about it again.

Then go to File and browse to an album. Open it, make sure it’s in playing order from top to bottom. Highlight from top to bottom, got to Tolls and Track Numbering and make the first number 01 in Destination Tag 1 and Tag 2.

Actually, now that I look at it I see Tag 2 has Cover Picture near the bottom of its list. If you see a cover photo,  uncheck that–the Clip doesn’t display covers, and images inside tags can slow down or stop the Clip.

Go to File and Save. Once you’ve done this a couple of times, it’s a five-second procedure for each album. Sorry Kid3 is a little more complicated than its Windows cousins…but that’s Apple for you…

1 Like