Sansa Clip+ repeatedly slowing down and freezing at certain points when trying to play music

I’ve had my current mp3 player, the Sansa Clip+, for probably the longest of any mp3 player I’ve had. I’m not against buying a new one but it would be nice to save this one if possible.

Yesterday my player started slowing down and freezing up when I tried playing a song. The LED(?) movement of the text transitioned very slowly for a few seconds, then just stopped altogether. I also noticed some of the text appeared “garbled” (or perhaps missing characters).

I can reset the player but the problem persists. I am able to plug the machine into my computer via USB, and it will say “connected”, but trying to access the actual inside of the player (via My Computer) happens very slowly or not at all. Unplugging will update the media and I am able to scroll up and down through the main menu options - Music, Settings, slotRadio, etc. - and the options within non-Music folders - I can look through the settings or try out the radio without it freezing.

However, I just now tried to record on the radio, and it did for a few seconds before freezing up. The same thing happens when trying to play uploaded music.

Any advice? I assume the problem may have something to do with the hard drive. I have recently been jogging with the player so I wonder if it slamming against my body, and being a few years old, has finally caused it to kick the bucket.


EDIT: Just tried it again, and now it froze at the logo startup.

There is no “hard drive” inside the unit; it is flash memory (ie solid state) so jostling it around while jogging won’t hurt it in the least unless there is a loose connection somewhere inside.

I would try formatting the player (you can do this easily in the Settings > System Settings menu). Note this will erase all user-added content so you will have to reload all your music, books, etc. afterwards. I would also re-apply the latest firmware that can be found here on the forum. One of both of these procedures should fix it. If they don’t, it’s a hardware issue and you’ll have to buy a new player.

Alright, looks like it’s done for. Thanks for the help anyway. :slight_smile:

Ah, don’t give up yet!  These little buggers have a way of coming back to life.  You might leave it alone for a bit and then come back to it.