HUGE Problem.

I’ve had the Clip+ for a little over a year now.

Yesterday, when I was listening to music inside of the store, I noticed the music suddenly stopped. I thought my headphones had stopped working, so I plugged them back in. I noticed the screen had gone dark, so I reset the Clip and it worked again.

Only it was now on the song I’d been listening to a while ago, so I hit the menu button to pop up the song lists, and it froze again. So I reset it again. It booted up on the same song, which I’ll call Track 13. I used the right button to continue onwards, only to pass a song I liked, so I hit the left arrow, and it froze again. I reset it, and it booted up on Track 13.

So today I finally said to hell with it, I’ll listen to Track 13. It played three seconds before the song fizzled out, it froze, and I had to reset it again.

Now when I disconnect it from the computer, it remains on the “disconnected” screen, with the battery still acting like it’s charging up. I just downloaded the new firmware, thinking it might help with my problem, but I don’t think it will.

Do I have to buy a new one?

Update: Firmware did nothing for the MP3 player.

It freezes ont he start-up screen, on the shut down screen, on the music screens. . . I think I might have to buy a new one.

It’s probably something about that “Track 13” that causing the problems. Either it’s corrupted or the ID3 tag is out of whack. Did you recently add this to your player, or has it been on there for a while? And has it played OK before?

If you can get re-connected to your computer, I’d remove that file, and any others you may have added at the same time. Dis-connect and see if the player works normally now. With any luck it should. Then you can run ChkDsk or Error-checking on those files and make sure the ID3 tags are of the format that Sansa mp3 players prefer, ID3v2.3 ISO-8859-1. Once corrected, you can transfer them back to your player.

No, it’s not this track. The most recently I added any music to it was last week. It’s been running smoothly ever since - it was just when I was in the store, and it froze.

I can listen to a song, but sometimes it freezes up halfway through, and I have to reset it, and then turn it back on again.

The ONLY other time I’ve had an incident was when the player miraculously deleted all of my music somehow, but back then I only had 200 songs, so it was easy to put them all on there again. It’s worked just fine ever since.

I honestly don’t know what happened to it.

I would try running chkdsk on your Clip and see if that catches things/fixes matters.  It does sound like a glitch–perhaps a file that became corrupted?

You also could try starting from scratch, again, by reformatting the Clip under its settings–as this will erase your content, transfer it back to your computer first, or be prepared to relaod the music (which might be an idea to do, in case there is a corrupted file there).

Unfortunately, I do believe the Clip+ has since died.

Yesterday morning I attempted to do a format, and after many failed attempts to access the correct form to get to the formatting screen, it just stopped working.

Now it refuses to turn on, be reset, or recognized by a computer. 

Looks like I have to buy a new one. :c

If I’ve learned one thing here, it is:  never give up the ghost.  These little Clips have been known to come back from the other side.

Sometimes it happens after just having been left alone for a day or 2.  Other times, it sometimes seems to happen after the Clip has been left plugged into a power source for a day or more.  I’d try each of these (I mean, what do you have to lose?!?).

You also could try telephoning SanDisk for help, and see if they have other ideas.  In the U.S.:  1-866-SANDISK (726-3475).  And other SanDisk contact information:  http://www.sandisk.com/sandisk-support/contact-us.