Sansa Clip + not recognized/failed to install

I’ve got a Sansa Clip + and the player itself is working fine, however my desktop PC won’t recognize it.

I’ve had the player for several months now and everything was fine until I lost the cable that came with the player. I have tried other mini USB cables and they work on other PCs, just not on this particular desktop. It gives me two messages: one about not recognizing the device and the other about failing to install it. The former message keeps popping up over and over again if that’s of any significance.

I have tried forcing the MSC mode (and MTP and auto detect), I have tried formatting the player, I have tried other cables and other PCs (as mentioned already), I have tried other USB ports on my desktop, I have scanned the PC for all kinds of crap, I have even tried pulling out the memory card, thinking (a long shot, I know) that maybe that could be causing some ridiculous conflict. In short, I have stalked all kinds of forums in the past week or so and, while I have indeed found posts with quite similar issues, there were no solutions to any of them.

Now, is there anyone out there who’s had a similar problem or who can figure this out. I have no idea what kind of info you need, but judging from the stuff I’ve read so far, it mostly revolves around the OS and WMP. I’m running Windows 7 Ultimate and the current media player version is 12.0 (updated it yesterday in hope that something might change, but no luck).

Let me know if you need any other info.

It’s the cable. I tried another Sansa Clip cable I borrowed from a friend and it works. Apparently this PC only recognizes the device if I use a cable that came with the clip. I’m guessing it has something to do with that cylindrical thing in the middle of the cable, but I have no idea what it does. Anyone care to explain this?

tried with my clip + cord still says new hard ware is found for MTP device and access denied 

The “access denied” message may pop up if the device is not recognized properly, if there is a weak connection, or if there’s a glitch with (MTP) Windows Media Player.

I have noted that the Clip+ can be more finicky with longer Mini-B USB cables.  By switching to the original (short) cable, the connection can often be better.

Depending upon whether you use MSC or MTP mode, when using the Device Manager, the device will show up differently: in MSC, you’ll find it listed under the USB Root Hub, at the bottom of the list, and in MTP, you’ll see it listed under Portable Device.

By using the manage function, shown in this Knowledge Base tip, you should be able to restore the connection.

There are two alternate steps available as well, if the Clip+ is still stubborn.  If Windows Media Player is the culprit, you can try deleting the wmpinfo.sys file from the root directory of the device (you will have to set Windows Explorer to show “hidden files” under the Tools > Folder View tab), then try reconnecting after removing teh file.  Transfer a file again with Windows Media Player and the file will be restored.

As a last resort, you can use the Format function on the Clip+ to clear the device, and start fresh.  I list this one last, since you’ll have to reload your music, as formatting clears all media from the Clip+.

Bob  :smileyvery-happy: