Sansa Clip help please?

My 2GB Clip has 784 gb of songs on it, and will not allow me to add more. It says: ‘Cannot copy Seether-Broken: The directory or file cannot be created’. I’ve tried formatting it by pc, formatting it throught the mp3 player’s menu, doing an error check, defragmenting it. I once deleted the folders and other things and then it allowed me to add several more songs only then when I tried to play it the screen said, please free 30 mb. I saw a thread saying to perform a disc check after this kind of message, so I did that again but it didn’t work this time either. I just removed a few songs and then it was happy again (back at seven-eighty-something mb) It used to work beautifully, but my pc went through a crap stage and all of a sudden it wouldn’t admit the clip’s connected. After many attempts at everything (during this time when I connected it to other pcs, it did get acknowledged) including formatting it, the pc did give me the pop-up window of which action to take- but only “media player” and “no action” were there. Upon opening ‘my computer’, the player never appeared at all. I could only open it in media player, which never works properly- I add a couple of songs there but the player says ‘no songs’. Yesterday I discovered ‘USB modes’ and tried MSC mode, which allowed me to finally open in a folder again. I joyfully selected all the songs I want on, but it just won’t let me add more than around 780 mb. I’m desperate, please help. Orah

If you have copies of the music on the host PC, I’d simply format the device using its built-in Format command:

Settings > Format > Yes.

Then reload your freshly cleared Clip.  Oh, and never defragment a flash-based device, as this messes up the wear leveling system used to extend the life of your flash memory.  Defragmenting was designed to optimize sequential (rotating) data storage and access.  It isn’t necessary for a bank of flash memory, as we have no moving parts, only electrons.

Bob  :stuck_out_tongue: