Sansa 2gb Clip- can't add music!

When I originally got the sansa 2gb clip I loaded it up with music and haven’t really changed it since. I tried to add more music today and managed to delete everything! Not such a problem as I just started loading it up again. However I’ve only been able to add 175 songs- a lot less than I had on it before…and it keeps saying full! Surely I should be able to add more…any advice on what I’ve done wrong?

Are you using WMP (Windows Media Player) to load music? If yes, it might be WMP is set to automatically sync files to your Sansa.

Format the Sansa first then follow step 3 on this Knowledgebas article.

An easy fix, as long as you don’t mind losing the content on your Clip (you always can copy the content over to your computer first):  format the Clip under its settings.

@siobhan wrote:

When I originally got the sansa 2gb clip I loaded it up with music and haven’t really changed it since. I tried to add more music today and managed to delete everything! Not such a problem as I just started loading it up again. However I’ve only been able to add 175 songs- a lot less than I had on it before…and it keeps saying full! Surely I should be able to add more…any advice on what I’ve done wrong?

Sounds like you only think you managed to delete everything. Could be you’re using the infamous Auto Defect Mode which can connect in either MTP or MSC at will and without your knowledge and/or consent. Files can only be viewed on the computer while connected in the mode the files were originally transferred in. So if you have some transferred in MTP mode and then are connected in MSC mode, you won’t be able to see them, making you think they have all been deleted. You load them up again & whammo, suddenly you’re out of space because now everything is doubled up.

Might not be what’s going on, but certainly possible and worth checking out. I’d probably format the thing and start over. Manually select a specific USB mode to operate in and don’t trust/use the Auto setting.

@siobhan wrote:

When I originally got the sansa 2gb clip I loaded it up with music and haven’t really changed it since. I tried to add more music today and managed to delete everything! Not such a problem as I just started loading it up again. However I’ve only been able to add 175 songs- a lot less than I had on it before …and it keeps saying full! Surely I should be able to add more…any advice on what I’ve done wrong?

Sounds like you only think you managed to delete everything. Could be you’re using the infamous Auto Defect Mode which can connect in either MTP or MSC at will and without your knowledge and/or consent. Files can only be viewed on the computer while connected in the mode the files were originally transferred in. So if you have some transferred in MTP mode and then are connected in MSC mode, you won’t be able to see them, making you think they have all been deleted. You load them up again & whammo, suddenly you’re out of space because now everything is doubled up.

Might not be what’s going on, but certainly possible and worth checking out. I’d probably format the thing and start over. Manually select a specific USB mode to operate in and don’t trust/use the Auto setting.