Trying to load songs

My husband and I bought our sons Sansa Clip MP3 player for their birthdays.  We have only had them for 3 days.  I have been ripping CDs and storing the music in our Windows Media Player then loading it to the players from there.  I have loaded 156 songs.  The players are only 24% full.  They still show that they have 1505MB of free space left.  They will not take any more songs.  I get an error message that says “the file or folder cannot be created”.  I can’t figure out what’s wrong with it.  I need to know what’s wrong, how to fix it or something.  Otherwise it’s back to the store for them.

Surely someone can help?  My sons love these players, but want more songs on them.  If I can’t figure out what’s going on and have to take them back, they will be crushed.  They specifically picked these players out themselves because they really liked them.

What computer, Mac or PC?  What operating system? If Windows, Windows XP with SP2 or above, and WMP10 or above?

I’m using a compaq presario with windows ME. 

On the off-chance:  do you know if you are transferring the songs in MSC mode?  Go to the Clip’s Settings/USB, and set it to MSC; or put the Clip into hold and connect it to the computer while holding the center button own.  See if tht at helps.

Ok, I tried that and it didn’t help.  There were a couple songs on one of the players that one of my sons didn’t like so I deleted them off and it let me put one in their place.  It’s like the player is full, but it still is only showing that it is 24% full.  It says that it has 1522 MB free and 1949 MB memory.  Why is it acting like it’s full then?  I’m so confused.

Lets start over.  Format the devices and please update the firmware to v01.00.20a.

next set MSC mode.  And try to fill the devices from WMP. the other approach is to use Windows explorer and drag and drop the songs to the "Music folder "  on the device. 

Exactamundo.

The format command is under the Clip’s Settings.

If you don’t have copies of the music elsewhere, first copy the music over to your computer–the format will erase the Clip’s file contents.

Good luck with this!

UGH!!  I tried this and it did not work.  I have it loaded again to 20% this time and it won’t take any more songs.  Says an error occurred and it says that “The directory or file cannot be created.”  So, what else is there to try?

Hi,  I have a Sansa clip 2GB and I load songs using Windows Explorer.   However, I am running Windows XP MCE.   Not sure about Windows ME?

In the Clips “Settings” mode, and under the USB item, I keep this in Auto-Detect or in MFT.  I have trouble in MSC mode.  I only use MSC to update firmware.   All my music is in MP3 format,  192 kbps. 

I had this same type problem with a cheap Ebay Hong Kong special and it was bad memory.   You may have a defective unit.  Just take it back and exchange it. 

I agree that formating is a good idea but if it doesn’t help, take the unit back for an exchange. 

/jds

Well, we are having this same problem with 2 different units.  They were both bought at the same time, but it would still be hard for me to think that both units were defective.  I’ll try loading them like you said…who knows?  After doing this for the 3rd time, maybe it will work.  I’m sick of trying, though. This is rediculous. 

have you tried to do a disk check on the device yet?

Take it back, Windows ME is not a supported OS for the Clip.

I was afraid of that.  What devices can anyone recommend with Windows ME?