Error Message please help

my sansa clip is saying an error message “not enough space for music DB, please free 4 MB”  and my computer wont even recognize it  nor can i turn  on the clip. After that message pops up it shuts back down, does any body know how to fix this?

Not sure if this will do it, but turn on your clip, put it in hold (side the power switch all the way down until a lock comes on the screen), hold the center key (round), and while holding the center key, plug in your USB cable.

It should show up as a flash drive.  Delete some files to free the space it needs.  You might want to format it if there is still space left.  

Hope this helps!  Good luck!


First, it’s best to try a reset: hold the power switch in the ON position for 10 seconds, then release.  Then try powering up the Clip again.

If this is unsuccessful, there are two steps to try next.

First, simply plug your Clip in to the USB port, and see if it’s recognized.  If it is, be sure that the machine is charged for a bit, I’d recommend at least the 50% point on the Clip’s display.

Then, disconnect.  Does the display state “refreshing database”, then all is back to normal?  It’s possible that the music database was fouled up.

Now for the second part.  If the basics didn’t work, time to roll up the sleeves a bit.  Start with the Clip OFF, and slide the power switch to the HOLD position (orange showing).  Hold the center button down while plugging in to the computer, keeping the button held until it is recognized.  The Clip will say “connected”.

Go to My Computer and look for your Clip.  Click on the Clip logo, and check if there is indeed memory space available.  If there are a few hundred MB free, the message is referring to the database only, and we can try to clear this database first.  The sansa will build a NEW one automatically from scratch if we delete it.  What happens in corruption cases is that the device tries to add to a gnarled file, and will hang up in the process on reboot.

At the top of the Windows Explorer screen, click Tools > Folder Options > show hidden files.  We are looking for mtable.sys , which will be in the root directory of the Clip.  Note: the Clip stores the music database here in the root directory, but it shows up only in MSC mode.  Right-click on this file, and delete it.

IF the problem was with this file, when you unplug, all should be well after the database refresh.

Now for some fun.  If the Clip still does its shutdown trick as before, I’d suggest that it just might need a refreshing of the firmware.  Reloading the firmware will not kill your music files; perhaps, we can save all of them.

Load a new copy of the latest firmware by using the manual MSC mode method used above, by following the directions here, for the 1.01.29 Firmware. You can print out the directions as a guide by first clicking the options button in the upper right of the post, then select “print”.

Remember that the firmware is compressed (zipped), and must be unzipped prior to installation.  Be sure to drop the file in the root directory, meaning the main Explorer window that shows the Clip’s folders, but NOT into one of the folders; the same place we found the mtable.sys file is our “drop zone”.  If you cannot drop the file into this root, there’s a memory problem, and you must either format the Clip to free the memory, or delete some files from the music folder for space.  To see these files, it’s important theat “show hidden files” is selected, if they were transferred in MTP mode.

Once the firmware copy is loaded, uplug, and the display will show “firmware upgrade in progress”, then the device will shut off.  Power up, select your language, and you’re ready to run.

Bob  :smileyvery-happy:

Message Edited by neutron_bob on 05-19-2008 08:18 AM

i have the same error message and i tried all of the fixes posted above. nothing worked. when i hook it up to my comp. (with vista installed) and i open up wmp, i can see all my songs in the sync’d list on the right side but i cannot delete any songs. i can remove them from the list but that does not seem to free up any memory.

this is a 1gb clip. this was givin to me and i do not have any original software, if there was any. am i faced with the only option i see which is the pop up that wmp gives me when i open it and that is to delete all files on the clip.  would like to avoid that, but if it is last choice…

thanks for any help 

Plug in your Clip and navigate to your music using Windows Explorer. 

In MTP mode

Double click on the Clip (picture of a Clip)

Double click on Internal Memory

Double click on the Music folder

Right click and delete any of your music

Hope this helps.

Go Sansa!

Firstly is this what you did to get that message? (or almost what you did):

  1. Connected Clip to PC in MTP mode.

  2. Used WMP, Rhapsody, Napster, Windows Explorer, to upload content to full.

  3. Disconnected from PC.

  4. Free 90MB shows.

Then. . .

  1. Connected to PC, and it connects as MSC mode.

  2. Can’t find files to delete to free space.

If that’s what happen, than the fix for it is:

  1. Connect Clip to PC (it’ll connect in MSC mode if that Free 90MB message shows).

  2. Right click on Sansa Clip ( X: ) (X can be any letter).

  3. Choose format. click Ok.

  4. Discconect Clip from Pc to refresh DB.

So the reason behind it is this. In previous firmwares, there was a bug for MTP mode where you can fill up the device and it will cause that Free 90MB message. This is not suppose to happen in MTP mode. Anyways once that message shows, the player defaults to MSC mode, but in MSC mode you don’t see the music you uploaded because you uploaded it in MTP mode. SO that leaves with a huge problem, you can’t free space because your in the wrong mode, and you can’t go back to the original mode to empty music. Sadly, formatting by windows explorer is the only way to fix this issue. The new firmware ending in 29 should have this issue fixed.

Hopefully this was your issue to begin with, and it solves your problem.

Message Edited by thoma on 05-28-2008 11:22 AM

I have version .29, and it happened to me. Formatting cured it, but fix this **bleep** thing Sansa.

"In previous firmwares, there was a bug for MTP mode where you can fill up the device and it will cause that Free 90MB message. This is not suppose to happen in MTP mode. "