Sansa Clip hangs on turn on.

I got the 4G Sansa Clip last week.  I upgraded to version and have been using it to listen to Audible audio books.  Today I tried to turn on the Clip and it displays the Sansa logo for booting up.  Then it just hangs.  I tried resetting, and it hangs again.  The only way I can get it to work is if I power it off, then plug it into my computer.  It then boots up fine, and I can unplug it, but if I power it off again, it won’t get out of the Sansa logo screen, unless powering it on through my computer.

I’m not sure what caused the other two posts. . . . I only hit submit once.

Anyway, I deleted every file and reloaded the audio books with the audible manager rather than windows media player and it booted up fine.  Anyway, it boots up fine now.  I used wmp so I could rename the files to be shorter names so I can tell the differences between the parts of the books without waiting 45 seconds for the name to scroll to the end of the file.

well seemed like you were able to solve your own issue. I’d like to suggest performing an explorer format after you upgraded your firmware before doing anything with the player. a lot of the times this helps to prevent any DB refresh issues.