Sansa Clip died within 30 minutes out of box

I bought 2 Sansa Clips (2GB, 1 black, 1 red) from BestBuy the day after thanksgiving, and i opened one of them the first day that I got it. It worked fine, except for some bugs. Today, I opened the second one (red) so that I could get it ready for my mom to use. I updated the firmware on both to 1.01.18A, and then added an overdrive audiobook to the red one. I uplugged it so that I could update the black one, but as soon as I unplugged it, it did something weird on the screen and it showed a lock.

Whenever I plug the Clip in, nothing happens. The screen doesn’t turn on, nor will the computer recognize it as a device. This happened 30 minutes within opening the box, and nothing happened to my black Clip when I did the same thing to it. Is there any way to fix this, or can I just send it in for repair? Could I also exchange it with Best Buy for a new one?


EDIT: Nevermind, I fixed it. I dont know exactly what did it, but i held the on button up for a minute and did a few other things, but it finally came back on after a few tries.

Message Edited by Raseac on 12-12-2007 01:44 PM

Try resetting the Clip by holding the power switch up for about 10 secords or so.   Then see if it will mount again.   Another thing to try is to charge the battery for a while, possibly with an USB power adapter.   Once it has charged for a while you can try the reset procedure again.

Try putting it in recovery mode then update the firmware.
Hold switch on and press and hold center button of wheel. Then connect to PC

Maybe you can also try formating the player from within after you get it running.


What you did is reset the device.  If you read the manual, to reset (recover) the device,  just slide and hold the power button for about 6 seconds.  Usually, this would solve most of your problems.  That’s why it’s nice to read the manual once awhile to see what other features do the device offer so that you can have a better experience with them.