Sansa Clip+ 8GB suddenly not recognised by pc

I bought my Sansa Clip+ 8gb back in October and have sync’d it a few times with no problem. Went to do so again today and whatever USB port I use I get a pop up saying the device is not recognised and subsequently Media Player tells me nothing is connected. The Clip+ is working and playing with no problem I just want to add so stuff to it.

I have tried 3 different ports as well as 3 different USB cables.

When I click on the pop up I get this message:

One of the USB devices attached to this computer has malfunctioned & windows does not recognise it.

USB Root hub (2 ports)

Sansa Clip+ 8GB

unused port.

(bizarrely there is only 1 port there not 2!)

When I tried it in a port at the back it showed the right number of ports.

I tried another device (camera) in single port and that worked with no problem. Memory sticks are also working ok.

Any ideas?

Set the USB mode on the player to msc. See if it will connect properly in msc mode. Which Windows are you using? Some people have had trouble connecting in MTP mode using Windows XP SP3.

Message Edited by JK98 on 02-15-2010 04:12 PM

I’m running XP SP3. Not sure what mode the Clip+ is in, whatever the default is, I will try your suggestion tomorrow. I tried it on my laptop and it installed itself no problems but won’t let me sync (except once only) as I’ve already set it to sync with the pc and apparently it’ll only allow one or other not both. There’s nothing on the laptop to sync, I just wanted to see if it would recognise the Clip+.

It’s been working fine since October, just today it’s decided to go loopy on me!