Sansa clip 4gb display not working


Display is not working in my sansa clip 4gb. i cannot see anything on the display, but the clip is able to play the songs, please help me rectify this problem


Did you try a system reset?  Clip off, hold the on switch uppermost for 15-20 seconds. 

It could be a hardware failure.  Are you still under warranty?  If so and the above doesn’t work, you may need to contact SanDisk customer service (telephone is easiest) for a warranty replacement.

i got mines less than 3 mths ago and it worked fine unitl i was at the gym and it just went out, at first i thought it was the battery, but when i plugged it into the usb on my pc, it’s still not doing anything, or responding to me pressing the on/off button on top? what gives?? i don’t have the full capacity of the space used up so i’m really clueless as to what i could have done or what went wrong

This is probably the most asked question or “problem” posted about here. All it requires is a simple reset. Press and hold the power button for 20-30 seconds. Release, then press again momentarily to turn it on. It should start up normally.