Sansa Clip+ 4g Skipping Songs

Hi everyone~

I bought my beloved Sansa Clip+ 4g (V01.02.15A) several years back and about a year ago it started skipping songs and it’s always the same ones everytime (unless god forbid I download new songs and it decides to start skipping those too!). At first I thought that this was just because the songs I got from rhapsody had expired (I was getting a message everytime I started the mp3 saying that tracks had expired and I had to go to my mp3) but when I went to redownload those songs using something other than Rhapsody the problem continued.

I’ll just be listening to my music and when one song ends, instead of going to the next, it will skip it and several others. Sometimes it skips only one or two and other times it will skip almost twenty. This is not only affecting songs I downloaded a long time ago but also some-what recent songs I’ve gotten in the past few days/months. This is really annoying me since I really want to listen to these songs and have been redownloading them over and over only to get the same result.

In addition to this, the songs won’t even show up in the “recently downloaded” list. They’ll show up in “all songs” though which really confuses me.

Furthermore, I’m pretty sure that there’s nothing wrong with the files themselves (all in .mp3 format) since they’ll play normally on my computer in the “My Music” section where I originally downloaded them from. When I try to play them from their sandisk location though (still on my computer) none of the songs will play and I’ll get a message saying that they’re in use. This happens to all of my songs and not just the ones that get skipped though which makes me think that there’s nothing wrong with it not playing there.

Is there anything I can to fix this or will I just have to put up with it and delete the songs? Thanks in advance for answering, it really means a lot to me since I love this mp3 and don’t want to go get a new one. (T-T)

There could be some sort of file/FAT corruption that has occurred. I would try re-formatting, which will erase everything and optimize the memory (do it via th Format option in the Setting menu) and then re-transfer your files to the player. With any luck all files should play fine.


       I have been having the same problem with my Sansa Clip+ 4GB and it is driving me around the bend!!  I just want to make sure how you Re-format it without making things worse…

In the ‘Settings’   I select   ‘System Settings’.… then there is an option to 'Restore Factory Settings’ and when I click on this it asks me if I want to Restore Factory Settings?

But there is another option in the ’ System Settings’   called 'Format’ and when I click on this it asks me if I want to format the device?

Which one is the correct option? :confounded:


      after reading other threads about re formatting I went for this option… 


My device cleared all the music that was on there…

I then tried to add music again and the same thing is happening so back to square one… :confounded: