Sansa Clip+ 4bgb just wont work

I got my clip about 1-2 months ago, and it worked fine until rather recenlty. The deal is that I switched over to Mediamonkey because I don’t really like WMP or iTunes much at all, and I tried syncing it, and then when I think it was finished I closed it (it was at least 3.5 hours later and then it just wouldn’t work.

It starts up with the flower thing, but it takes like 5 minutes as opposed to the usual time and then it just shows either a green screen or a really pixelated screen, and I tried ressetting it like 5 times, and I checked online for advide, but it didn’t help and it wont be accepted or read by my computer. 

What do u guys and girls think I should do?

Leave it on until the battery runs down and it shuts off.

Plug it into your computer to charge (it may take a while before it turns on and incidctes that it is charging).

If it starts up and makes a data connection with your computer, format it (which will remove all user-added content) and manually re-apply the firmware.

Thanks I will try that. I let it completely die once, but it didn’t work, but i’ll try it again.