Sansa Clip 1 GB Won't Charge

I can plug it into my PC and play/add songs on the clip but it just won’t charge. Under properties it always says the charge is at 0%. I’m using Windows Vista (64 bit) and the clip’s firmware version is 2.01.16A (can’t update it w/o power). Is there anything I can try or would this be a hardware issue with the battery? I’ve tried formatting and setting it on hold while holding down the center button until it’s recognized but none of that helps the charge. Any ideas?

one thing is to make sure ur laptop isnt in sleep or hybernate mode when its charging or it wont charge… also walmart sells these ac/usb adapter things that you can plug the usb into and charge it that way. u can get them with an ac and  car charger etc. just depends on what ur needs are. this has come very useful for me. ur battery on ur laptop just may not be giving off enough juice to charge ur mp3… Good luck!

I’m on a desktop not a laptop and my usb 2.0 ports charge other devices well including another Sansa Clip. It’s just this one player that’s giving me problems. Has anyone else had this issue and is there something I can try?

It’s probably a hardware issue and I’ll take it back and exchange it. Thanks.


I have the same issue, and read in another forum that it is caused by the ‘auto detect’ for the usb settings not functioning properly. If you go into the setttings and change this from auto detect, to one of the other 2 usb options, it will get it charging again.

Have you tried changing USB ports? On a Desktop pc use the ports on the back.