SanDisk Ultra microSDXC 128gb card Corrupted


I’ve got a 128gb sandisk sd card that I’m seemingly unable to do anything with after having transfered some files to it. It takes forever to load in windows when connected to the computer. When it’s finally loaded after about 10 minutes it’s displayed as a drive that doesn’t have any used/max storage space and you’re unable to open it. It can’t be formatted either by right clicking and selecting format. In Disk Management it’s displayed as a removable drive of 119,08 gb. It’s also Unallocated. 

I’ve tried running a chkdisk on it but recieve the error message that it’s a RAW file format so it’s unable to complete the chkdsk command. 

I’ve tried diskpart but I’m unable to clean, create partition primary, or format since I keep getting a “Incorrect function” error message.

Any suggestions?


Seems like a counterfeit card that is labeled as a larger card but is still some GBs big. If you bought it from ebay then you can be 90% sure that the card is counterfeit.

For more clarification you can contact the sandisk support to see if the card is genuine.