Sandisk Ultra Micro SDXC 128GB shows 30.6 MB capacity

Okay, so here is the problem I have had since Monday.

i was in the middle of an uber hectic day and without a warning my Samsung Galaxy 5 suddenly restarted in the middle of a call. The only way I knew it is because I heard Samsung’s boot tone when it restarting. After it booted up, it showed a warning of a blank SD card and asked me if I want to format it, which I choose “YES”, and afterwards, it returned with an error messae, and keep looping.

At that point I removed the micro SDXC, plug it into Sandisk adapter and plug it into my computer and to my surprise it showed 30.6MB space. I tried to format it, but it says the disk is write protected, but it is not. It won’t let me format it, so I have tried and use other programs, like SD Formatter, HP Disk Format Tool, Gparted and some other programs, but none worked for me.

I guess I have to return it for a replacement, but I don’t know where I can return it to. I am from Indonesia, btw.

Any help would be great.

Sincerely,

a desperate SDXC owner

Hello,

in that case you cannot do anything more with the card and its defective so you can replace it with the place of purchase or contact sandisk direct to replace the card in the warranty.

Hi deponia,

How can I contact SanDisk dirctly for a replacement? I have tried to contact them thru http://kb.sandisk.com/app/ask/

but no response from them.

I guess I will hv to go to the reseller.

Thanks for your reply

Hello,

in that case you can also give them a quick call and ask them to find your mail to assist you at once. i think in that way its faster.

the link can be found here: http://www.sandisk.com/about-sandisk/contact-us/