128GB microSD causing issue with my Galaxy J5

I recently bought a Sandisk Ultra 128GB microSDXC card as I’ve run out of space on a 64GB one. I put the empty card into my phone and formatted it, transferred some stuff over to it on my laptop, then put the card into the phone. It took about half an hour for everything on the card to show up in Gallery, Play Music etc, but eventually I could access everything that was on the card.

it worked perfectly until a few hours later when I went back to the phone and tried to play some music from the card, but got ‘Couldn’t find the track you requested’. I then got a notification saying ‘Device storage full’. I checked Storage in settings, and it said I had only 58KB of internal storage left (this fluctuated between 9MB and 0KB). I tried to open the music player and Gallery, but got a notification saying ‘the process android.process.media has stopped’. This happened every time I tried to open an app or settings too.

I was able to check the internal storage and saw that around 600MB was now taken up by an application called ‘Media storage’. This disappeared after removing the card and switching the phone back on, then reappeared when the card was in the phone. I’ve run both SD Insight and chkdsk, which both flagged up nothing.

I asked on another site and was told to try ‘wiping the cache partition’ on the phone, which resulted in me getting ‘Damaged SD card’ when I tried to mount it to the phone.

Any help would be greatly appreciated,

from what i can find online “media storage” is an adroid app that parses metadata of the files. this is not an app that is specifically related to the card. Rebooting the phone should allow it to rebuild the databases and may help with the issues. 

is the card working when it is connected to a computer? can the card be formatted normally? If format completes and you insert the card in the phone empty do you see any similar issues? if not reload your content and try it again and see how it works. 

Thanks for your reply, I’ve been able to format the card while it’s in the phone, and it still works normally when connected to my laptop. I have tried the card empty and got the same result.