SD card not working properly


I bought a SanDisk Ultra 128GB microSD XC I

I have tried to insert in my laptop and use it. I have tried all kinds of formats, but the readable size from the windows PC remains at 23 GB.

I have opened also the disc management tool of windows but there is only one partition of 23 GB size.

Also, the card is not readable at all from my Windows Phone Lumia 950 / Windows 10.

Any path to follow before I return it?

An update:

I managed to format for 23GB using exFAT and then inserted it in the phone, and it was read.

I formated it in the phone again and it appeared with capacity 119 GB (hooray). however when I started copying files, it can only take up to 8 GB. Then eiter I get error:

An unexpected error is keeping you from copying the file. If you continue to receive this error, you can use the error code to search for help with this problem

0x80070057: The parameter is incorrect

Or, if I try to copy a folder, I get a warning that the folder is too big, regardless of the size.

Can I assume that I have damaged goods and proceed with return? I am relactunt because I need to leave for vacation in a couple of days…

Did you buy it from a reliable, authorized SanDisk delaer? From what you describe it sounds like a counterfeit/fake card to me.

I suppose one can never know since I buy a lot online. The price however was standard and having contacted the online shop they say they are verified resellers.

I wonder if there is a way to establish that. But in any case there will be return and refund.

Wouldn;t SanDisk want to know if there is someone out there selling fakes?

SanDisk knows there are a lot of fakes & counterfeit cards out there. In fact, if you call tech support, they can verify for you if it is genuine or not by the serial number on the card.

You can also run h2testw on the card to verify for yourself if it’s real.

It is really infortunate that I already sent it back. I would love to know.

I did use the h2testw tool however before I returned it.

How can you extract the conclusion if it is a fake? I cannot run another test, but I have saved a result from this test:

Error writing file ‘E:\24.h2w’, offset 0x4f00000.

It is still possible to verify the test data written up to this point.
(The parameter is incorrect. Code 87)
Warning: Only 121935 of 121937 MByte tested.
Writing speed: 15.8 MByte/s
H2testw v1.4

Can you tell from this if this is a fake?

The error occurs as soon as 8GB are put into the card.

Unfortunately I did no save the serial number of the card.

Thank you!