Unable to format my Sandisk Ultra Plus 16 GB MicroSD

Hi, I purchased this product roughly an hour ago from Bestbuy. It was sealed in it’s case, so there’s no way it was a return.

When I insert the SDCard Adapter with the microsd card in it to my computer, it asks to format the disk. So the Windows Format Removable Disk shows up and says my card is 30.6 MB… When I click Start to format, with the default given options, it returns back that it’s unable to format.

I have tried the SDCard Formatter 4.0. It just tells me it’s write-protected, even though the switch is not at write protection mode.

I do have a MicroSD USB Reader. I have tried it this way as well and it does not work.

I’d love to get some assistance.

:smiley:   Hi Delicate Glow,


Dear member of SanDisk Community, welcome.


Sorry, the UFD they come formatted, of factory, and it is not necessary or desirable to format it again.
When the device (phone, camera, PC, etc.), asks to format, should be suspected:

or is defective (“write protected”), or it’s fake.

Do not grieve more, return it.

Luck, and then you tell us, what happened, please.

Regards, Alfred.                                                                (Google translated)

Okay, I returned it and got another of the same card.

I now have different issues with this card.
First, the Windows Format Removable Disk doesn’t even know the capacity to it. Nonetheless, I can’t format it.
SDFormatter 4.0 wont let me even let me attempt to format. the Format button is disabled. It just says “This drive is not supported”

If I try to insert the MicroSD card into my MicroSD USB reader and connect it to the computer, it doesn’t detect it.
If I insert this card into my old smartphone, it reads it correctly and stores files just fine. However, I don’t use this phone anymore.

What is going on?

I found out my issue.
Both my USB MicroSD card reader and laptop’s SD slot weren’t able to format/read it. I don’t know for what reason. But they were a couple of years old.
I bought a new card reader today. I could open the drive just fine and format it.
Hope this helps some people.

Thank you! That helped me out. I had had an issue like that before but forgot about it. I used the usb micro sd adapter that came with the card and it works pefrect. I love the sandisk class 10 cards they are all I buy i dont trust the others