Faulty 16GB Micro SD Card

Hi All. I have been trying to get help in being able to use this card again. It is a Sandisk 16GB Micro SD (Transflash) and it has worked well for many months then one day it just stopped working. If I put it into a computer is recognises there is a card but instantly says I need to format it, even if I accept this it says cannot be formatted.

NOW, When the format box comes up, in the ‘Capacity’ box it shows as 30.6MB. I cannot change this even after trying all formatting options all I get is ‘Windows is unable to complete the format’

I have accepted the fact that I have lost all the data on it, but really want to get it going again.

Funnily enough I also have a 8GB of same type from which I recovered the data, but won’t let me format it as it thinks it has the little write protection switch on, but obviously the micro SD car doesn’t have a switch. I have put it into an adapter and moved this switch but to no avail.

Any help would be great.



Hi, I have the same problem but with a SanDisk 8 GB MicroSDHC (class 4, I think)  card. It worked well on my HTC Legend for a month plus - I could read and write on it - and then without noticing it, the care write-protected itself. I only realised this recently when I downloaded a file and took some pictures with the phone. Everytime I tried to access the new files either through my phone or PC, the file “mysteriously” disappears. The old files are still there and I can make a backup of the card.

I have tried formatting it via the PC format feature and the SDFormatter from sdcard.org web site but to no avail. The PC format formats it as per normal but tells me at the end of a full format that “Windows is unable to complete the format”. SDFormatter tells me from the start that the card is write-protected and tells me to unprotect it first.

I have tried using the recommended troubleshooting steps of using and microSD adapter and toggling the physcial lock switch e times, keeping it at the lock position for 30 seconds and finally sliding to the unlock position but to no avail also.

My dilemma is that I do not want to do a one-to-one exchange as the data can still be read and copied, and I do not want them to get into the wrong hands. So a one-to-one exchange is not a solution for me. I want the card to work! Please help to advise on a method that I have not tried.



‘Still’ waiting for a reply from SanDisk UK, despite two emails, the US department was an instant communication but sad to say no one from UK department is responding???  Poor show so far  :(

I have this very problem. I can’t format , delete files from, or unlock the 16gb micro sdhd  card. I’ve tried everything. Help please SanDisk.

I encountered the same trouble before. Fortunately,I used this data recovery program to recover my pictures on it successfully. I think this article will help. You can check it out!

After you recover the pictures,you can try to format the card to check out whether it can be fixed.

Well…I have this exact problem…

I have a Sandisk Extreme Pro 16GB SDHC myself…Worked great untill yesterday, when it apparently figured it would be a good idea to go die or something… This severely pisses me off, I’m unable to format it, I’m unable to write to it, I’m unable to delete anything… And here I go buying SanDisk due to needing something that will last :confused:

I’m calling the shop I bought it from… The card is just over 2 months old, sure hope these cards are supposed to “live” longer than this.

@r_m_i wrote:

The card is just over 2 months old, sure hope these cards are supposed to “live” longer than this.

With a Lifetime Limited Warranty (30 years in Germany) I would assume they are.

Hello JKwok, May I inquire as to whether you solved your problem with your SD card? I am experiencing essentially the same anomaly with my SD card, and I feel the same way you do about wanting to protect to contents of the card. I want to exhaust all possibilities of retrieving the data that is on it (my last back up was a few weeks ago). To me, it seems very interesting that so many people all report the same 30.6mb when their card failed. To me, I am at the very least, curious as to what exactly failed on the card and why it failed, if for no other reason than to help me purchase a better class card that is less inclined to fail, given how great the inconvenience and cost of the loss is when a card I am relying on fails in this way. If so many cards all appear to have the same failure, I would expect somehow to be able to get an explanation. Please let me know what you found out, if anything. Thanks. -John

out of the millions of these cards on the market the reports are really not very significant. i can gurrantee it will be less than 1%. that said it would apprear to me to be a controller failure since it is reporting the capacity incorrectly but that is just a guess. most companies I have delt with dont release information on spicific failures unless there is a need for recall and at less than 1% failure rate this is not a recall situation. 

Same exact problem here with my 16gb MicroSD HC card. Called : 866-726-3475 and 45 minutes later they are replacing my card. There is a lifetime warranty on the card. The call center is in India so be prepared to be very frustrated and repeat yourself numours times! The technician I spoke to treated me like I was quite computer illiterate. I had to use the phonetic alphabet (alpha, bravo, charlie…) so he could understand me… Overall this will be my last Sandisk purchase for lack of customer service!

edit : looks like I am going to have to call them back as the guy setting up my RMA hung up on me. JOY…JOy…joy! 

I have also the same issue I can’t format , delete files.I’ve tried everything.I need help.

SanDisk Tech Support

@doughlas789 wrote:

I have also the same issue I can’t format , delete files.I’ve tried everything.I need help.

SanDisk Tech Support

 My 16GB Sandisk SDHC has been replaced 3 times over the past 1 1/2 years. Every time the sector fails, Sandisk only offers a replacement.  But by then the damage is done and who wants to use an unreliable card for your priceless photos or important document?

My trust in this product/brand has deterioated enough so say that I’d NEVER buy another SANDISK product. Their support is unhelpful and provide no suggestions on how to remedy the problem or give alternatives what so ever.

@ejepsen wrote:


<not worth repeating again> 

3 separate posts saying exactly the same thing?

Your contractor called. He said your bridge is almost done and you can move back in under it tommorrow.

Hei everybody!
My problem was that I bought sandisk 16 gb micro sdhc class4 memory card and from the first day I couldn’t format it on my computer. Windows cmd didn’t help and format through my computer said that windows was unable to format.
When I connected my sdhc card with my galaxy ace what’s running on android 2.3.6 it offered me to format it straight away and nothing happend. On the notification bar it said that sdhc card is blank or in different file system.
So the situation was same like with everybody else in here…
I MANAGED TO FIX IT!!! / at least so far its still working!

  1. I put the micro sdhc card into my phone and connected my phone to my windows 7 pc.
  2. in my phone I went to settings - sd card and storage - mount (in some point it didn’t mount but after trying few times it did)
  3. then I took down my notification bar and clicked “use sd card as storage” / “use sd card in storage mode” or something like that.
  4. then took my pc by using that https://www.sdcard.org/consumers/formatter/
    it found my sd card. Only setting what I changed was… Full overwrite erase format( NOT QUICK FORMAT )
    Format took about 30-45 min.
    After that I took my phone and safely removed from computer, took the sd card out put it back in and the phone said it is damaged sd card. I went back to settings - sd card and storage and mounted again and it started working… Phone said that I have 14.8gb or something like that free space and I was able to store stuff through usb to phones sd and everything seems to be working so far!
    I hope that will help everybody!!!
1 Like

Don’t know as it will help everybody, but it should at least help somebody. :stuck_out_tongue:

Thanks for posting!

1 Like

Hi there , I bought a microSDHC Card  32gb to use with the car camera , it worked fine for 3 days then it started to have problems . ( I bought the card from an online retailer in Australia)

I can access the card with the camera connected to the pc (Windows 7) , I can open the folders and see the files but can’t open anyone of them , the pc just hang.

I have tried to format it with the camera and pc in every possible way available , nothing work , messages I get are : media is write protected , volume could be corrupted,can’t be formatted etc…

Program use : SD Formatter, HP Storage formatter , disk management , etc…

Hp Formatter doesn’t even work if the card (in the adapter, unlocked) is insert in the pc. Some of them just hang until I remove the card.

I wanted to check if the card is original but nothing work.

I’ll send it back to the sender and see what he has to say . Communication was very poor , he just told me to send it back . (Maybe this is not the first time). Bought it from ‘crazyshopping.com.au’  (That was cleaver of me :flushed:

hi just bought 16gb class 4 micro sd sandisk  card from amazon.


put into a cheap card reader  from amazon (which supposed to read up to 32gb) http://www.amazon.co.uk/MICRO-SD-MICRO-SDHC-MEMORY-READER/dp/B002WKD0CQ/ref=sr_1_7?s=computers&ie=UTF8&qid=1344328099&sr=1-7 

and connected to my usb2 port on my pc tower with xp sp3

some files copy, others crash/close the window with error/fail message  .   i re-open the  window and try again and sometimes it works , sometimes i repeat this process a few times until file copies over completely (and window does not crash or close).   but usually crashes again when trying to copy another file.  completely random. crashes on files as small as 10mb.

never crashes when reading the files.    have almost filled the card with fully working files trying to understand it and see if the capacity was there.  is is.    so i’m assuming it’s not a fake card as it is 15/16gb tested.

was 7 uk pounds so not overly bothered about returning unless fully sure card is faulty.    at themoment not sure if it is reader or card.

It would be inexpensive enough to try another card reader.

Edit: I see 4 others have complained (in reviews) that they too had problems with this reader. 3 didn’t work off the bat and 1 failed after a couple of weeks.