Faulty 16GB Micro SD Card

This describes my scenario exactly - right down to not wanting to do the exchange.  I have tried the SD formatter listed in the replies and I chose the options full erase and full overwrite.  This is when the micro SD is in a USB stick with no write protect switch.  I also put it in the SanDisk full SD sized adapter and made sure the switch was set to write.  I tried the switch in the other direction - multiple times and nothing works.  The SD formatter says it is write protected and Windows simply tries formatting for a while and eventually fails.  I tried a low-level formatting program and it just gave error after error.  Any ideas?

My suggestion if you want to protect the data but take advantage of the 1 time exchange option. Copy the data from the disk, to 2 different sources (so you are sure to have it) then get a big magnet and rub it all over the disk, on both sides. The data will be gone and you can send the disk in. Of course I do not know what anyone else woulod saay about that. When I used to have 3.5" disks, before I tossed them in the trash I used to mag wipe them, same for video tapes, etc.

I have a micro SD Sandisk 16GB and why does it show on windows MY Computer 14.8GB instead of16GB?

@gram20122022 wrote:

I have a micro SD Sandisk 16GB and why does it show on windows MY Computer 14.8GB instead of16GB?

Because that’s the actual usuable space on a 16GB card.

1% failure rate may not sound like much but it sure leaves a lot of people extremely dissapointed

when you are a part of that 1% it is a 100% failure for you!

I have a 16GB Micro SD card for my phone and i had the similar problem. My phone randomly decided not to read the card… i tried to format it and it was write-protected, so i got a Micro SD Adapter and Unlocked it then put it in my pc and formated it like that,  works fine now :slight_smile:

I purchased my SanDisk 16GB microSDHC from Amazon nearly a year ago and exactly the same reader as frag-frog and everything worked fine. I could see it in Windows, Linux, and on my Rikomagic MK802 II but today I tried to use it to load up a new image for my MK802 and it won’t read. It’s not recognised in Linux or the MK802 at all and Windows 7 seeems to see it and then doesn’t and then it does so on and so on but never long enough to be able to do anything with it.

I also have the SD Adapter for the MicroSD card and this doesn’t help anything on the Windows 7 PC

It does seem to make the card recognisable on my Linux Laptop with builtin SD reader but cannot read any files, delete or create pratitions and cannot format the card.

P.S. With regards the RMA I am expected to pay the postage to  Czech Republic

Postage = £3.00

Cost of new SD card = £8.54

No brainer!

After 2 or 3 years (I’m not sure which one is exactly because I’ve purchased two identical cards from amazon.fr, one in 2011 and one in 2012) and the card failed on me with the exact same symptomps as the ones described in the original post. So you people say that SanDisk replaces such faulty cards? How should I proceed? Thanks!

Well, thanks to the astounding Amazon Customer Service representative, I’ve got my money back and I can purchase a new card. Thank you SanDisk, I really though your products would last, it’s the first time one of my SanDisk cards fails on me.