cannot format micro sd, believe me, i tried everything

i have a 64gb micro sd card class 10 sdxc. im using it on my note 2. ill give you a summary of what happens. when i take pictures and store it on my memory card its ok, but when i restart my phone all the files i have it dissapears. i tried using numerous types of file explorers but it just dissapears. now im formatting the card in my note 2, but after it formats the card, after i restart my phone, all the files that was formatted comes back as if it wasnt formatted at all. i tried doing this more than 5 times still same result. i connected my note 2 on my laptop and tried formatting it there, after it formats and shows that it is succesful and formatted my card, after i rstart my computer or phone, or simply close the dialog box, it reverts back to the original state as if it wasnt formatted at all. i tried connecting my micro sd to its sd adapter, inserted the card directly to my laptop, buy it keeps saying that it is write protected. i know how to unlock the adapter (the switch on the left side), i even tried putting the switch both in opposite sides (up and down), but it still says that it is write protected. i tried using different adapters yet it says that it is still write protected and cannot format the card. i tried putting scotch tape on the side of the adapter, still it says it is write protected and cannot format the card. i tried go into the administrative tools>disk management>micro sd and formatted thru there, yet it says cannot format disk drive. ive tried formatting thru run>cmd>diskpart>list disk>select my card>format fs etc, it says cannot format card due to an error. i would lkike tothink that the card is broken and corrupted, but the thing is, i can still access my pictures and videos inside and can copy files without a problem so i know the card still works and is not broken. the only thing is there is NO WAY in formatting the card, it either shows an error that it is write protected, even in using different adapters and toggling the lock switch, or it formats but after restart of phone/computer or reinserting to other device, it reverts back to the state where it wasnt formatted at all. please, with all the things ive done, i need your help.
PS
i tried scanning using different antiviruses (kaspersky, avg, avast, malware removals etc) and it shows no viruses or malwares or spywares. please do help

2 Likes

the same happened to me 4 days ago with my gopro 3 black edition.
I tryed format it on the camera, on the laptop with adapter, i tryed almost everything… I still see the files and i can access them and copy to my pc as well, but i can’t delete them or format the card, windows not allow.
I’ve tryed some recovery programs, i recover lot of old files that i had deleted already from the card and the last ones before it stops working…
So it means that can have a chance to fix this i think, because aparently it’s working…
I contact sandisk and i’m waiting for the answer

1 Like

This is eerie, I have the exact same card in the exact same phone with the exact same problem. I cannot delete any information from the card without it restoring itself, I also cannot add files bigger than a picture to it without it becoming corrupted. I would also appreciate some assistance. I have mailed Sandisk about it and hopefully I will get a response but who knows.

Any update from sandisk regarding this issue. I also encountered the same issue. This is my 2nd 64gb sandisk class 10 which faced the same issue. The 1st one was replaced as it is under warranty. Now the 2nd has no warranty anymore. Please share any info from sandisk. Thanks.

@supremo wrote:
This is my 2nd 64gb sandisk class 10 which faced the same issue. The 1st one was replaced as it is under warranty. Now the 2nd has no warranty anymore.

These cards have a limited lifetime warranty on them. Why does your 2nd one (replacement) not? Is that the limitaton, only one warranty replacement per customer?

Here in Phil when they say 1 year warranty, they will replace it for as many as you want as long as its inside the warranty period. In my case , the 2nd card is outside the warranty period of 1 year. How is your card?

It happened to my 64gb ultra sdxc sdcard some time ago and I’ve tried a lof of methods too to format it but nothing was succesful… So the only way out is sending it to a service? Where should I send it if it was bought in Poland?

@supremo

hi, could you guide me how I can get my sd card replaced? i bought mine at gamextreme, i still had the receipt - i just can’t remember their return policy. were you required to surrender the non-working card? TIA.

Hi All

I’m facing the same issue as I’m not able to format my Sandisk SD 64GB Card. I tried all the ways to format it  but no way and no solution so far. I thought it’s only me but after i have done some google searches i found many people d=facing the same issue. what a lose of data and money!!!.

YOU MAY AS WELL SNAP THE F*UCKING THING THROW IT AGAINST A WALL AND PI*SS ON IT BECAUSE YOU WONT GET ANY SUPPORT FROM SANDISK LOSERS

Exactly same with me.  I am using also Note 2 with 64G sd card and facing the same problem.  I have tried whatever program such as SD Formatter 4.0, Disk Manager, EASEUS Partition Master, DiskGenius, Hard Disk Low Level Format Tool and etc but failed to fix it.  Please give us response!!!

Ditto on the symptoms in my Samsung Galaxy Note II.  My 64GB SDXC sarted doing the same things after nine months of perfect service: videos won’t delete, pictures from my camera corrupt and it won’t format.

The OS on my phone hasn’t updated in quite some time and nothing else weird occured.  I submitted a request for a warranty replacement since I’ve only owned it for almost ten months.  I don’t really expect a resolution but wanted to post my experience here too.

I cant believe there are a lot who is experiencing the same thing. Just notice this happening to me a few days ago now its stuck to the contents it currently has. I hope there is a fix for this

I’m having the same issue with the 64GB SDXC and my Note 2. My Note 2 was recently updated to Android 4.3. Up until then things were working fine. But recently images that I have been taking have been corrupted and can’t be viewed or played (in the case of videos). 

I can not reformat the card either. I’ve tried in Windows 7 and receive a Format Complete message. And the card says 59.47GB available, but then all of my pictures come back, and I’m left with 20 GB. These files were supposed to have been deleted in the formatting process. But apparently not.

If there is write protection on the card then that makes sense.

This is frustrated. Any solutions yet?

Thanks,

Joe

I have ever encountered the similar memory card problem before. In order to save both of this card and inner stored data, I have also tried a lot.

Firstly back up all stored inaccessible data with the help of some card data recovery tool like 4Card Recovery

http://sd-card-format-recovery.blogspot.com/2013/11/recover-sd-card-after-formatting.html

And then try to format this card with a professional card formatter, though this formatter finally cannot format my card successfully.

So, I have no choice, but to replace this card latter.

But, fortunately, I have rescued my data with that data recovery tool.

Note: Just learn a lesson to back up all important data at least on two memory cards or drives in the future.   

After I purchased this card, not quite a year ago, I read forums similar to this about the 64gb micro SD card and Note 2s. Well it fianlly happened to me. I didn’t realize I had a problem until I tried listening to music on my phone and it not recognizing any music from my card. What is really surprising is that this thread is on SanDisks site and they have not chimed in on this problem. I am on Amazon a lot and Kingston chimes in whenever they see a rating of 3 stars or lower. I guess I’ll try reaching out to SanDisk.

I’m facing the same problem. If this isn’t resolved, I’ll have to post a negative review of the card on Amazon.

FYI, my card is the:

SanDisk Ultra 64GB MicroSDXC Class 10/UHS-1

http://amazon.com/gp/product/B009QZH6JS/

 

I’ve tried all the recommended format methods, can’t format/delete/write to this card from either Windows or Android. I even tried formatting via a camera, and it didn’t work.

You can resolve it by simply calling Sandisk for a warranty replacement.

Thanks, I’ve submitted a message to support via the site, but I’ll also call. Also, when I checked today, there already were plenty of negative reviews on Amazon from other customers with this problem.

Add another one to the list. Mine was in a Samsung Tablet Note 10.1

Bloody annoying after 18 months being perfect.

I will wait to see what happens to you guys