Sandisk Ultra 64GB can't be formatted or permanently altered

The Sandisk Ultra card on my Note 2 allows for run/edit/delete files just fine, until I reset the phone. Then all the files will return exactly the same as they were.

Basically, my photos until 2-Nov-2013 are all there, and I can create new photos, but the moment I reset my phone (or take the card out), all photos after 2-Nov will be gone.

The worst part is I can’t even format the card – even by Windows Disk Management. It goes up to 99% before it gives an error like “The format has not been completed”.

Formatting by phone is the same. The phone will say “Total Space: 59.47GB”, “Available: 59.47GB” after I manually delete all files using Astro File Manager, but the moment I try to format the card, it checks it and comes back with the same old files.

What the heck is going on? Any help would be appreciated

You could try formatting with the SD Association’s Format tool.

Thanks for the suggestion. I downloaded it and tried, but it says “The Memory Card is write-protected”.

It most definitely is not. I can edit and delete stuff manually on my phone - even though it appears again later - so it seems there is something quite wrong.

1 Like

Hi I am having the same problems. And I’ve tired of it so it has been months now since I’ve tried to reformat my card. Any help would be be appreciated. The card is accessible but unable to get in any new info and it can’t and refuses to reformat. PLEASE HELP. Pretty please?

MESSAGE POSTED 11-11-2013

STILL NO REPLY

**bleep** YOU SANDISK YOU SUCK

i have this problem too,

i won’t buy sandisk again, i always tell my self that it’s not gonna happen again, and this cards still sucks

Exactly same as me.  I am using also Note 2 with 64G sd card and facing the same problem.  I have tried whatever program such as SD Formatter 4.0, Disk Manager, EASEUS Partition Master, DiskGenius, Hard Disk Low Level Format Tool and etc but failed to fix it.  Please give us response!!!

i am also facing the exact problem with 64gb class 10 sd card for my note2. i was downloading a video. after completion i was able to play it once and then i found that the video cannot be played anymore. after a week’s usage i found out that i am not able to write any data on the card and the card is write protected now as i lost my week’s data and pictures. i have used all possible methods of removing or formatting the data including various formatting tools like hp etc. tried cmd and by converting it into system volume. there is no possible way out. even exposed it to magnets but my memory card has the data permanently saved on it. i always thought and heard that sandisk cards were really reliable which is dead wrong. i will not recommend anyone to buy sdcards of sandisk and rather go for kingston. i spent my 65$ in a wrong place. 

Same with my problem.i’am using galaxy s4 with sd card 64 gb ultra!i’am tryng format,Always fail!
Windows says,format not complete/write protected/etc.etc.!
Please help me!do you have solution for my problem?thank’s before!

Same problem there. I can finish formating, but after reinstalling SD card all old files come back again. May be the only way to fix this is to buy a new one

Also have the same issue. Samsung Galaxy Note 2, Sandisk Mobile Ultra 64GB. 

Hi All,

I too am having problems with my SanDisk Ultra 64 GB MicroSDXC Class 10 UHS-1  installed in a Galaxy Note 2. Everything was working fine until the last few weeks. My phone was recently updated to Android 4.3 and now I am noticing this problem. Also I have about 39 GB of pictures and video on the card and also in the last few weeks I am getting corrupted pictures and videos when I take new images. 

I tried reformatting the card in Windows and it says Format is complete. But then all of my pictures come back again.

Totally frustrating.

Joe

Welp…I can’t add, delete, or format anymore, and it appears this issue is shared by several owners of the 64gb card. Sadly I don’t see any response from Sandisk, or anyone, on how to resolve it. Are we just screwed and stuck with a crapped out card…

On a positive note…I was able to pulled stuff off the card that I wanted and save to my desktop until I get a new card.

@keithd203 wrote:

 Sadly I don’t see any response from Sandisk, or anyone, on how to resolve it.

 

 

Apparently you haven’t contacted SanDisk about it. This is a User’s forum.

http://www.sandisk.com/about-sandisk/contact-us/

My sd card 64 gb sandisk ultra uhs clas 10. I can format from my mobile phone but when I plug in computer its dont work.

My os win 7 and see 1mb and file system seening only FAT not fat 32 and I’m tired of seeing name of SDFormatter…

SD scard won’t format to the proper size.

 

I’m having exactly the same problem.  All of a sudden, the MicoSD card is in a “frozen” state… I cannot write to it… I cannot delete it… I cannot format it… It “appears” to work… and it appears to accept alterations… but when you remove it and reinsert it… it goes back to the way it was… any deleted files magically reappear and anything new added disappears.

WORTHLESS… Never buying SanDisk again.

I am so relieved. My 64GB SDXCi in a Note 2 has been acting oddly this last couple of months. Apps not finding data; media players not playing files. I’ve tried all the things that other correspondents here have tried. I’ve downloaded and tried several 3rd party formatters (one of which took a while to clean up after it also installed a load of unwanted stuff). I reckon I’ve spent nearly  3 full days trying to sort it out and in the end I gave up and got another card. Which works fine.

My relief is because I thought I was going mad - or stupid. These posts from others with similar experiences are very reassuring, even if it is a shame that Sandisk has not  owned up to the problem.

I am happy to say that when I reported to Sandisk my problem with this card and the umpteen measures I’d taken to try to deal with it -  unsuccessfully - they very quickly accepted that the card is faulty and sent me an RMA to return it for replacement. Given that things in this world do go wrong some times, I am impressed with their response. Though I do still think it would be good if what appears to be a known problem with this card were better publicised.

You have to replace it because its corrupted… Simple     :cry:

SAME EXACT PROBLEM

No way of formatting.

Frozen state!!

I believed it started the day I upgraded to 4.3 too (Xperia Z1). This is weird.

ps: I live in Argentina so there is no way of RMA for me :frowning: